• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI crashing before initializing Loader Class

#1
[eluser]Unknown[/eluser]
Hello,

I am trying to load the following url index.php/Ajax_admin_tabs/general.
The code for the controller is:
Code:
<?php

class Ajax_admin_tabs extends Controller
{
    function Ajax_admin_tabs()
    {
        parent::Controller;
    }
    
    function general()
    {
        $this->load->view('admin/General_tab');
    }
    
    function forums()
    {
        $this->load->view('admin/Forums_tab');
    }
    
    function users()
    {
        $this->load->view('admin/Users_tab');
    }
    
    function groups()
    {
        $this->load->view('admin/Groups_tab');
    }
}

The code for the view is:
Code:
<div>
  There is nothing to show yet
</div>

It is intended to be loaded via an ajax call, hence the incomplete html.

The log file is:

DEBUG - 2008-07-11 03:43:03 --&gt; Config Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; Hooks Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; URI Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; Router Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; Output Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; Input Class Initialized
DEBUG - 2008-07-11 03:43:03 --&gt; Global POST and COOKIE data sanitized
DEBUG - 2008-07-11 03:43:03 --&gt; Language Class Initialized

It seems like CI is crashing out before it ever gets to my code. I have tried going to the URL directly and going to it through the ajax request but they both give the same result.

I've been digging through the CI source to determine the problem but cannot even determine when the call to
Code:
load_class('Loader')
takes place on PHP 5. (I have only seen it called, with a second argument set to false if
Code:
floor(phpversion()) < 5
but I know that it happens from looking at other log files. suffice it to say that I am very confused and am going to bed. heres wishing for a 'magic answer' when I wake up...or at least a clue.

Thanks for the time,
Aaron


Messages In This Thread
CI crashing before initializing Loader Class - by El Forum - 07-11-2008, 03:00 AM
CI crashing before initializing Loader Class - by El Forum - 07-11-2008, 03:12 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.