Welcome Guest, Not a member yet? Register   Sign In
.htaccess issues help needed!!!!

My .htaccess now looks like this:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /wedding-site/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /wedding-site/index.php/$1 [NC,L]

<IfModule !mod_rewrite.c>
# If we don't have mod_rewrite installed, all 404's
# can be sent to index.php, and everything works as normal.

ErrorDocument 404 /index.php

but I still get the same xampp page appear.


This work for me:

RewriteEngine On
RewriteBase /wedding-site/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]


I now get the following error:

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
04/17/09 15:20:03
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

This is what i get ion the apache error log:
[Fri Apr 17 15:54:14 2009] [alert] [client] C:/xampp/htdocs/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Try this one ^_^
RewriteEngine On

RewriteBase /

RewriteCond %{ENV:REDIRECT_APP_PATH} !^$
RewriteRule ^(.*)$ - [E=APP_PATH:%{ENV:REDIRECT_APP_PATH}]

RewriteCond %{ENV:APP_PATH} ^$
RewriteRule ^(.*)$ - [E=APP_PATH:/$1]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /wedding-site/index.php [L]

[eluser]Daniel Moore[/eluser]
[quote author="learning_php" date="1239998252"]This is what i get ion the apache error log:
[Fri Apr 17 15:54:14 2009] [alert] [client] C:/xampp/htdocs/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration[/quote]

Your rewrite engine is not enabled in XAMPP.

Looks like the Windows version of XAMPP you are using. Open up C:/xampp/apache/conf/httpd.conf in a text editor. Search for a line that starts:

LoadModule rewrite_module modules/mod_rewrite.so

If the line is not there, then add that line to the file.

If the line is

#LoadModule rewrite_module modules/mod_rewrite.so

then remove the "#" from the beginning of the line to enable the rewrite engine.


I have add the line to the httpd.conf file and my site appears with the http://localhost/wedding-site/ but all the links still go to the xammp page?


I used to have the same problem when I first started using XAMPP on windows (using the extract only version)

First, backup your htdocs and mysql/data folder

The way I solved it, was by uninstalling it, and then using the installer version
After you install it (don't start the server up yet), don't visit localhost, but replace the htdocs and mysql/data folder with the ones you backed up earlier.

You can now start apache and MySQL, and visit localhost

For some reason, visiting the xampp pages seems to set something somewhere, which breaks things later on :S

I reinstalled and I now get this error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected]localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 Server at localhost Port 80

and this is the error log:
[Mon Apr 20 13:15:33 2009] [error] [client] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://localhost/wedding-site/


hmm... sounds like you've got an infinite redirect going on (the page you're redirecting to is sending you to itself)
Whats the content of the page you're trying to view?

Or try creating a simple page (either with or without CI) and see what happens

Theme © iAndrew 2016 - Forum software by © MyBB