Welcome Guest, Not a member yet? Register   Sign In
Problem with controllers in the URL
#3

[eluser]Volder[/eluser]
Thanks for your response.

Quote:>Did You define the constant HOME with ‘MAIN’ ?
sure in config/constants.php I have:
Code:
//default blog
define('HOME', 'main');

Quote:>Frankly, this is too mind-blowing for me. Do You think You’ll understand this next year when You reread it ?

actually, I don't find them difficult. Most of them are regarding pageN/->page/N/ modification.

Quote:>I avoid routing and set .htaccess up only after everything works.
all these configs and routing are working fine at my machine. So there were no problems during development. The problems appeared when I tried to place it to server.

Quote:>EDIT : take out Your .htaccess, change the config ‘index_page’ and see whether it works. If so, try the different flavours of the config ‘uri_protocol’
I used another approach.
I totally erased everythig from public_html folder.
Then putted there Codeigniter 1.7.1. version as it is available for download.
The only change I did is changed base_url to:
Code:
$config['base_url'] = "http://beauty-review.ru/";

Then I created my 'test.php' controller with the following content:
Code:
<?php

class Test extends Controller {

    function index()
    {
        echo 'We are on the test controller!';
    }
}

/* End of file test.php */
/* Location: ./system/application/controllers/test.php */

Then I go to my browser and input main site path: http://beauty-review.ru/
I receive a standard Codeigniter welcome message.

But when I change URL to http://beauty-review.ru/test/ I expect my controller to be processed, but it is showing me:
Code:
Not Found

The requested URL /test was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.7a Phusion_Passenger/2.1.3 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at beauty-review.ru Port 80

So now I do beleive that the problem is not in codeigniter and it's routing settings - but somewhere else even before php interpretator is starting to process.

Support of web hoster is continuing saying that there are no problems on their side.

Could you advise anything in such a situation?


Messages In This Thread
Problem with controllers in the URL - by El Forum - 05-23-2009, 04:41 PM
Problem with controllers in the URL - by El Forum - 05-23-2009, 06:39 PM
Problem with controllers in the URL - by El Forum - 05-24-2009, 12:10 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 12:19 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 12:26 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 12:38 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 12:48 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 01:04 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 01:13 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 01:21 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 02:12 AM
Problem with controllers in the URL - by El Forum - 05-24-2009, 09:13 AM



Theme © iAndrew 2016 - Forum software by © MyBB