Welcome Guest, Not a member yet? Register   Sign In
home controller functions not loading (uri protocol???)

I have a bunch of functions (like login, register) in the home controller that loads. The index function is loading okay but any of the other functions are not loading the pages.

I have a function called register() but I get a 404 when navigating to it. I've tried all the URI protocol's (PATH_INFO, QUERY_STRING, etc) but none seem to work.

Is there something I haven't configured? I really don't want to have to make separate files/folders for all of these controller functions.

Thanks for any help!


I'm having the same issue, except that calls to specific functions end up firing up the index function and not the requested function.

Does anyone have a lead on why this could be happening ?

haven't been able to solve the problem, but I've had to awfully create separate controller classes for each one. so instead of a register() function in the home controller, i have to have an entire Register class with its own index function.

however, the procedures inside that class seem to be working for subpages so it may just be a root issues. not sure why it's happening though.

I reduced the issue to the ID part of the URL actually not getting through. The function itself, when fired up without any parameter, is recognized.

ie : /controller/function does work
but : /controller/function/id does not work
and the index function is actually called.

This may have to do with the facebook environment / setting under which i'm developping, while using the install guide found here : http://www.simpleprojectz.com/2008/10/fa...deigniter/

I tried changing the uri_protocol to all values though.

Theme © iAndrew 2016 - Forum software by © MyBB