Welcome Guest, Not a member yet? Register   Sign In
[SOLVED?] [Oracle] UPDATE statement hanging up.

SOLVED: I guess a reboot fixed this? I'm not sure at all what was hung up. No log files are showing any obvious problems. My apologies to anyone who may have spent time looking at this issue and trying to correct it.

I'm in the process of trying to come up with a very simple test case, however I wanted to reach out and see if anyone has had this problem already. (my searching on google and on this forum pulls up no results).

When I run the code below, my browser just spins and the table is never actually updated. Within the same program, I can select data (even run a stored procedure which updates rows) with no problem. However, this tiny bit of code gets hung up.

I'm using CI 2.0.2. Windows 2003 server with IIS, PHP 5.3.1, and Oracle 10g.


class Test extends CI_Controller {
    public function __construct(){
        $this->db = $this->load->database( 'testdb', TRUE );
    public function index(){
        $sql = "UPDATE sage_application_instance
                   SET date_submitted = SYSDATE
                 WHERE id = ?";
        ## perform query
        $result = $this->db->query( $sql, 4 ); # a valid test id to be used
        ## capture number of rows affected
        $rows = $result->affected_rows();
        var_dump( $result );


Any assistance is greatly appreciated. This simple bit of code is really hanging up my project. (I have a feeling it's something easy that I'm overlooking.)

Theme © iAndrew 2016 - Forum software by © MyBB