Welcome Guest, Not a member yet? Register   Sign In
Beginner problems

Sorry, but i couldnt put this in the title


I just decided to start learning how to ude CI.
I downloaded the package and unpacked and wanted to start a tutorial. But i get this error message when i open it up in my browser:

Quote:Warning: set_error_handler() expects the argument (_exception_handler) to be a valid callback in /volume1/web/byvejen.dk/ci_blog/system/core/CodeIgniter.php on line 72 Fatal error: Call to undefined function is_php() in /volume1/web/byvejen.dk/ci_blog/system/core/CodeIgniter.php on line 74

I have done nothing to the downloaded files..

Can anyone please help get started?

I don't know what is the specific cause of your problem but you have clearly done something wrong in the install. Rather than trying to fix it, I were you I would just delete what you have and start again .... and very, very carefully following each and every step. This will be the easiest way. Good luck.


Seems like something wrong with your PHP dev setup.
What are using, WAMP Server or Something else.

Installation is very simple in codeigniter as just copy all the code into a directory in your web root and access it using the web browser.

If you need a good step by guide tutorial in learning Codeigniter - try my Codeigniter Tutorial

Thanks for your answers.

Unfortunately it still doesnt work.
I tried downloading a new install, unpacked it, uploadet it and changed my base_url and i still get the same error:

Im installing it on a Synology diskstation:

Server: Localhost via UNIX socket
Serverversion: 5.1.49
Protokolversion: 10
MySQL Tegnsæt: UTF-8 Unicode (utf8)
Apache/2.2.22 (Unix) PHP/5.3.10
MySQL klientversion: 5.1.49
PHP udvidelse: mysqli Dokumentation


For whatever reason, the file /system/core/Common.php is not being included properly. It could be a permissions issue, maybe a setting regarding capitalization in file names, maybe something is being corrupted when it is uploaded every time. I really can't be any more specific than that. Hopefully it'll get you in the right direction in helping solve the problem, though.

I kept on trying to upload the files and unpack the downloaded .zip locally and on the server. At last it just worked. Cant really say what went wrong, but probably some files got corrupted doing upload.

Thanks for the help

BTW: Love CI already Smile

Theme © iAndrew 2016 - Forum software by © MyBB