• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
so C.I. survived and with 3.0 it saved me from Lara-Hell ?

#4
@badpenguin

The minimal PHP version that CodeIgniter 3 supports is 5.2.4. After touching it at 2-3 places it could run on PHP 5.2.0 that have been released 8.5 years ago. Till the end of 2014 I tested regularly on PHP 5.2.0 for my purposes.

Old unsupported PHP versions are insecure, PHP 5.4 is the sane minimum today, but CodeIgniter 3.0.0 codebase alone (with minor changes) practically is capable to cover 10 years range of PHP server configurations. Probably it will run on stable PHP7 too, we'll see, this might extend this coverage even more.

Don't hesitate to upgrade your codebase to CodeIgniter 3. Such a upgrade would not be expensive, and it would extend the life of your codebase for about 4 years or even 5 (a subjective estimation).

CodeIgniter 4 will break BC with CodeIgniter 3, but I think a rewrite CI3 -> CI4 would be cheaper than a rewrite CI3 -> other framework.
Reply


Messages In This Thread
RE: so C.I. survived and with 3.0 it saved me from Lara-Hell ? - by ivantcholakov - 04-23-2015, 12:03 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.