Welcome Guest, Not a member yet? Register   Sign In
cli cron job fails to see controller

Hi Team,
The docs seem a little terse to say the least, but I have a problem running my cron job which ran successfully on a similar site.
The site I am having the problem with is up to date with latest CI, and I have chosen to move the application folder outside of the website root, which I understand is a good security thing to do.
The site generally runs well (php5.6), so this CLI problem is a bit odd.

The command I run via the website owners crontab is: /usr/bin/php5.6 /webroot/index.php cron index password. I have also tried Cron as suggested by a post on this sort of problem. Neither works and I end up with the following text in my logs:

ERROR: Not Found

        The controller/method pair you requested was not found.

So, is the cli broken, because it follows the docs quite well?

I have tried changing the file mode of the controller to 755 without any success either.

Can anyone point me in the right direction please?

Thanks, Paul

No, it's not broken.

Debug it as if you see a 404 on the web; it's the exact same thing.

Sorry - I'm an idiot!
The message is because my code is spitting out 404 error hence this exception.
I hope I havent wasted anyones time :-(

Theme © iAndrew 2016 - Forum software by © MyBB