• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
a problem with get_where

#5
[eluser]Code Arachn!d[/eluser]
I'm having this same issue - I've double checked the code and can with certainty say that there is a weird bug happening with the query. What's weird is that on my development server it works as expected but on the production server (all code is identical) it throws the error:
Code:
Error Number: 1054
Unknown column 'invoice_type' in 'where clause'
I'm not sure if it's the version of MySQL since that is the only difference between the two systems. This is the code for the AR query:
Code:
$this->db->from('invoices');
$this->db->where('invoice_type', '107');
$this->db->where('invoice_status', '0');
$this->db->where('invoice_status_datetime IS NOT NULL');
$this->db->where('invoice_exported IS NULL');
$query = $this->db->get();
If I comment out the first where statement it will work perfectly fine.

Also I should note on this site I'm still using version 1.5 (I haven't noticed this problem with 1.6 yet like mentioned above)


Messages In This Thread
a problem with get_where - by El Forum - 03-26-2008, 03:33 AM
a problem with get_where - by El Forum - 03-26-2008, 03:42 AM
a problem with get_where - by El Forum - 03-26-2008, 03:42 AM
a problem with get_where - by El Forum - 03-26-2008, 04:39 AM
a problem with get_where - by El Forum - 04-02-2008, 01:15 PM
a problem with get_where - by El Forum - 04-02-2008, 03:51 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.