Welcome Guest, Not a member yet? Register   Sign In
getting file not found

I have included the AWS sdk in my third party directory.  I also add the above line to my module:

use third_party\AWS\S3;

This line is causing an error:

[font=Times New Roman]Message: Class 'S3Client' not found

Filename: controllers/Configure.php[/font]

[font=Courier New]$s3Client = new S3Client([
   'profile' => 'default',
   'region' => 'us-east-1',
   'version' => 'latest'

I have a file called s3Client.php in my third party directory. In it there is:

[font=Courier New]class S3Client extends AwsClient implements S3ClientInterface
   use S3ClientTrait;

   public static function getArguments()
       $args = parent::getArguments();

I have no idea why this is not working. Can anyone tell me ho to get my CI code to see the s3Client.php file?  
proof that an old dog can learn new tricks

Try renaming the file and replace the lowercase first character with an uppercase S.

Hopefully you've solved this already, but just for reference...


Simply using a namespace does not include a file...

Yeah I already solved that, but thanks.
proof that an old dog can learn new tricks

Theme © iAndrew 2016 - Forum software by © MyBB