Poll: Should CI4 rewuire PHP7.3 as a minimum?
Yes
No
Don't care
[Show Results]
 
 
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Should CI-4 require PHP 7.3 ?

#7
(03-10-2019, 03:30 PM)ciadmin Wrote: Are there any compelling reasons to consider 7.3 as a minimum version? (eg new features, new syntax, etc)
PHP7.2 made sense because 7.1 was out of active support, and for libsodium.

CI has historically tried to require as low a PHP version as practical, for maximum compatibility.
Moving to PHP7 was a big step, albeit a sensible one.
I've looked at what's new in 7.3, and nothing jumps out for me.

Perhaps it's a matter of exactly when v4 is released relative to Dec 1, 2019, when PHP 7.2 moves out of Active Support mode. It feels wrong to me to define the minimum acceptable version of PHP to be one that is not in active development. Then again, maybe it's a matter of 7.2 minimum and 7.3.latest recommended. No matter what it seems clear that testing under PHP 7.3.x should be pursued.

For me, the most compelling reason for consideration might just be the large number of bug fixes implemented starting with 7.3.0. There is a new patch version released every month too.
Reply


Messages In This Thread
Should CI-4 require PHP 7.3 ? - by dave friend - 03-09-2019, 01:36 PM
RE: Should CI-4 require PHP 7.3 ? - by InsiteFX - 03-09-2019, 03:37 PM
RE: Should CI-4 require PHP 7.3 ? - by php_rocs - 03-09-2019, 07:37 PM
RE: Should CI-4 require PHP 7.3 ? - by Leo - 03-10-2019, 01:53 PM
RE: Should CI-4 require PHP 7.3 ? - by ciadmin - 03-10-2019, 03:30 PM
RE: Should CI-4 require PHP 7.3 ? - by dave friend - 03-10-2019, 09:19 PM
RE: Should CI-4 require PHP 7.3 ? - by ciadmin - 03-10-2019, 11:20 PM
RE: Should CI-4 require PHP 7.3 ? - by puschie - 03-11-2019, 06:50 AM
RE: Should CI-4 require PHP 7.3 ? - by kilishan - 03-13-2019, 01:49 PM
RE: Should CI-4 require PHP 7.3 ? - by nogueira - 03-13-2019, 09:27 PM
RE: Should CI-4 require PHP 7.3 ? - by scalla - 03-21-2019, 02:16 AM
RE: Should CI-4 require PHP 7.3 ? - by NiteRaven - 03-14-2019, 11:29 AM
RE: Should CI-4 require PHP 7.3 ? - by Elvenrix - 03-14-2019, 11:34 AM
RE: Should CI-4 require PHP 7.3 ? - by sv3tli0 - 03-20-2019, 11:50 PM
RE: Should CI-4 require PHP 7.3 ? - by ronelb - 03-21-2019, 06:36 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.