• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to enable debug toolbar in CI4.0.0-rc.3

#24
(01-19-2020, 10:48 AM)littlej Wrote: Hello ! Yes, that is exactly what I am talking about. I had this thread in mind too.
It doesn't matter where you CI is placed on the server, it is the final url which is important. And, in your previous messages you said "www.domain.com/projects/CI4/".
What's happening if you add "?debugbar" to your url  ? Ex: http://localhost:8080/?debugbar

PS: The port is not important. I just wanted you to use "php spark" and CI's default settings, in order to have the "standard" configuration, and be sure this is not coming from your custom settings.

Hi Littlej,

The "www.domain.com/projects/CI4/" path is from Hbonds' post... I believe my layout and settings are as standard as they come (?):

/project / app (containing standard CI layout with Config/Controllers/Database etc folders)
             / openssl
             / writeable
             / system
             / public / index.php <-- base_url() => Apache's DocumentRoot
                         / .htaccess
                         / ... etc
                         / assets / ... etc

I had tried your "?debugbar" suggestion, thank you... but I get another plain-text-only webpage opening in a new window what seems to show the code of the debugbar function (it starts off like this:  document.addEventListener('DOMContentLoaded', loadDoc, false); function loadDoc(time) { if (isNaN(time)) {.... ).   Although the whole site's interface is JavaScript-based, I don't believe there is anything that should cause it to open and display a new page in my code (?).

I'm on a Windows platform, where I don't think PHP Spark is an option.

I wonder whether there is somehow a connection to this redirect() problem experienced by other folk, even though it only seems to be a path-related issue in this (and linked) posts:  https://forum.codeigniter.com/thread-75223.html... or is this just me grabbing at straws?

Gary
Reply


Messages In This Thread
RE: How to enable debug toolbar in CI4.0.0-rc.3 - by Gary - 01-19-2020, 01:21 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.