Welcome Guest, Not a member yet? Register   Sign In
CI4: Manual installation SYSTEMPATH/ThirdParty/Kint/init.php at line 47
#1

(This post was last modified: 03-30-2020, 08:39 AM by jreklund.)

Hi,

1.

I am trying to install fresh CI4, but unable due to error
Code:
SYSTEMPATH/ThirdParty/Kint/init.php at line 47

40 \define('KINT_PHP70', (\version_compare(PHP_VERSION, '7.0') >= 0));
41 \define('KINT_PHP72', (\version_compare(PHP_VERSION, '7.2') >= 0));
42 \define('KINT_PHP73', (\version_compare(PHP_VERSION, '7.3') >= 0));
43 \define('KINT_PHP74', (\version_compare(PHP_VERSION, '7.4') >= 0));
44
45 // Dynamic default settings
46 //Kint::$file_link_format = \ini_get('xdebug.file_link_format');
47 Kint::$file_link_format = 'xdebug://%[email protected]%l';
48 if (isset($_SERVER['DOCUMENT_ROOT'])) {
49     Kint::$app_root_dirs = array(
50         $_SERVER['DOCUMENT_ROOT'] => '<ROOT>',
51         \realpath($_SERVER['DOCUMENT_ROOT']) => '<ROOT>',
52     );
53 }

Xdebug already installed and xdebug.file_link_format = xdebug://%[email protected]%l is present in the php_ini.

Please, need advice!

2.
I think Manual installation is not complete in the User Guide. The are no mentions about dependencies like XDebug, Tokenizer extension of PHP and so on.
Reply
#2

I'm trying to install on linux, locally (apcahe2 php7) but I have the same error...(Manual install)

Some news?
Reply
#3

Hey guys, I ran into this error a while back.

I solved it by renaming system/ThirdParty/Kint/kint.php to system/ThirdParty/Kint/Kint.php

the K needs capitalising on linux servers I think? Hope this helps
Reply




Theme © iAndrew 2016 - Forum software by © MyBB