Welcome Guest, Not a member yet? Register   Sign In
4.0.3 works but 4.0.4 is broken for me

(07-17-2020, 05:37 PM)Sepharad Wrote: Auto-respone: if anyone is using xampp the quick way to fix this is open php.ini and uncomment:



Worked perfectly - thanks a mil

(07-18-2020, 03:48 AM)InsiteFX Wrote: If you had read the CodeIgniter 4 User Guide Server Requirements

You would have found your answer real fast.

I am having the same difficulty, but using a Mac (Catalina).

When I go to start the development server from terminal with php spark serve I get the same error.
With the default mac installation of php I can not find the ini to uncomment the extension.  

If I php --ini I get the following: 

Quote:Configuration File (php.ini) Path: /etc
Loaded Configuration File:        (none)
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)

In /etc there is no php.ini to edit. I googled to find a way to create an additional php.ini, but was not able to find anything useful. How does one go about this?


If you move any folder from where spark is you need to edit spark and change the path
from public to where you moved it.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )


I'm not exactly sure what you mean. I didn't move any folder. I am talking about the error message from the initial question:
Fatal error: Uncaught Error: Call to undefined function CodeIgniter\locale_set_default()

If I add if function_exists() to the initialize() function in ./system/CodeIgniter/CodeIgniter.php as User John_Betong suggested everything works, but I realize that this is not a good workaround.

The question is: How can I change the php.ini for the default installation on Mac OS, without having to install a second version of PHP through Homebrew or something? Or can I some how load the intl extension using the spark file?


Theme © iAndrew 2016 - Forum software by © MyBB