Welcome Guest, Not a member yet? Register   Sign In
CodeIgniter v4.0.5 and v4.1.0 released
#17

(02-01-2021, 02:12 AM)nc03061981 Wrote: Thanks,
But no guide for upgrading from v4.04 to v4.1
i was using 4.0.4 and just ran composer on development web in apache :

Code:
bash-5.0$ composer update --no-dev
Loading composer repositories with package information
Updating dependencies
Lock file operations: 0 installs, 26 updates, 0 removals
  - Upgrading codeigniter4/framework (v4.0.4 => v4.1.0)
  - Upgrading doctrine/instantiator (1.3.1 => 1.4.0)
  - Upgrading fzaninotto/faker (dev-master 26c3c62 => dev-master 5ffe7db)
  - Upgrading laminas/laminas-escaper (2.6.1 => 2.7.0)
  - Upgrading myclabs/deep-copy (1.10.1 => 1.10.2)
  - Upgrading phar-io/manifest (1.0.3 => 2.0.1)
  - Upgrading phar-io/version (2.0.1 => 3.0.4)
  - Upgrading phpspec/prophecy (1.12.1 => 1.12.2)
  - Upgrading phpunit/php-code-coverage (7.0.10 => 7.0.14)
  - Upgrading phpunit/php-file-iterator (2.0.2 => 2.0.3)
  - Upgrading phpunit/php-timer (2.1.2 => 2.1.3)
  - Upgrading phpunit/php-token-stream (3.1.1 => 4.0.4)
  - Upgrading phpunit/phpunit (8.5.8 => 8.5.14)
  - Upgrading sebastian/code-unit-reverse-lookup (1.0.1 => 1.0.2)
  - Upgrading sebastian/comparator (3.0.2 => 3.0.3)
  - Upgrading sebastian/diff (3.0.2 => 3.0.3)
  - Upgrading sebastian/environment (4.2.3 => 4.2.4)
  - Upgrading sebastian/exporter (3.1.2 => 3.1.3)
  - Upgrading sebastian/global-state (3.0.0 => 3.0.1)
  - Upgrading sebastian/object-enumerator (3.0.3 => 3.0.4)
  - Upgrading sebastian/object-reflector (1.1.1 => 1.1.2)
  - Upgrading sebastian/recursion-context (3.0.0 => 3.0.1)
  - Upgrading sebastian/resource-operations (2.0.1 => 2.0.2)
  - Upgrading sebastian/type (1.1.3 => 1.1.4)
  - Upgrading symfony/polyfill-ctype (v1.19.0 => v1.22.0)
  - Upgrading twbs/bootstrap (v4.5.3 => v4.6.0)
Writing lock file
Installing dependencies from lock file
Package operations: 0 installs, 3 updates, 0 removals
  - Downloading laminas/laminas-escaper (2.7.0)
  - Downloading codeigniter4/framework (v4.1.0)
  - Downloading twbs/bootstrap (v4.6.0)
  - Upgrading laminas/laminas-escaper (2.6.1 => 2.7.0): Extracting archive
  - Upgrading codeigniter4/framework (v4.0.4 => v4.1.0): Extracting archive
  - Upgrading twbs/bootstrap (v4.5.3 => v4.6.0): Extracting archive
Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files
2 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
Generating autoload files
Generated autoload files
bash-5.0$

wiget at bottom of page is now displaying :


Code:
System Configuration
[url=https://codeigniter4.github.io/CodeIgniter4/index.html]Read the CodeIgniter docs...[/url]
CodeIgniter Version:
4.1.0
PHP Version:
7.4.1
PHP SAPI:
apache2handler
Environment:
development
Base URL:
http://127.0.0.4/
Timezone:
America/Chicago
Locale:
en
Reply


Messages In This Thread
RE: CodeIgniter v4.0.5 and v4.1.0 released - by captain-sensible - 02-01-2021, 05:09 AM



Theme © iAndrew 2016 - Forum software by © MyBB