Welcome Guest, Not a member yet? Register   Sign In
command "composer update

I downloaded the https://github.com/codeigniter4/framewor...v4.1.3.zip, unzipped it. And in terminal i'm in this folder, and running "composer update" i received:

Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires PHP extension ext-intl * but it is missing from your system. Install or enable PHP's intl extension.
To enable extensions, verify that they are enabled in your .ini files:
    - C:\xampp\php\php.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Can somebody helpme?

I found. In php.ini uncommenting extension=intl. It works.

(This post was last modified: 08-05-2021, 06:32 AM by captain-sensible. Edit Reason: added about re-starting xampp )

i think it might be to do with php.ini

it looks like your on Windows ; i'm on Linux but there is usually equivalence . I checked my php.ini file , i have under dynamic extensions section :


find yours and I suspect it will look like this:


the ";" in front of "extension=intl" means its not enabled so use a text editor and remove the ";" at the start of the line and try again. I vaguely remember I also had a problem with composer and update . until i edited php.ini

ps you might have to restart xampp to see if that fixes it. i re-checked my php.ini I also have


i.e curl extension enabled

(08-05-2021, 01:28 AM)is123 Wrote: I found. In php.ini uncommenting extension=intl. It works.

thats odd when i was looking at your post , the second one wasn't visible

The PHP version also influences the enabling/disabling of extensions.
In PHP 8 versions the gd2 extension, for example, should be disabled, which in previous versions was not necessary.

Theme © iAndrew 2016 - Forum software by © MyBB