Welcome Guest, Not a member yet? Register   Sign In
Why i get CI 4.2 instead of 4.9?
#1

(This post was last modified: 06-06-2022, 11:41 AM by luckmoshy.)

Hi I try to get a new CI 4.9 but I get 4.2 via composer

composer create-project codeigniter4/appstarter pr
Do Codeigniter Before Do You!
yekrinaDigitals

Reply
#2

Dude stop smoking that weed =)
Reply
#3

4.2 is the most recent version. The previous version was 4.1.9. Is that what you were expecting?
Reply
#4

Hey guys - let's keep the forums friendly, please. No need to be insulting.
Reply
#5

If you need to install v4.1.9 for some reason, try:

Code:
$ composer create-project codeigniter4/appstarter:4.1.9 pr
Reply
#6
Heart 

@luckmoshy  The latest version released is now 4.2(See)
That's why you get it.
If you want to get the previous version(4.1.9) use:

Code:
composer create-project codeigniter4/appstarter:4.1.9 pr
Iran,talesh,datamweb Heart
Reply
#7

(This post was last modified: 06-06-2022, 07:32 PM by luckmoshy.)

(06-06-2022, 06:06 PM)datamweb Wrote: @luckmoshy  The latest version released is now 4.2(See)
That's why you get it.
If you want to get the previous version(4.1.9) use:

Code:
composer create-project codeigniter4/appstarter:4.1.9 pr


Thank you @datamweb because before I used that way and I got it right but I then try and got 4.2 so I was surprised why it gives me 4.2! ok any way thank you

(06-06-2022, 03:10 PM)kenjis Wrote: If you need to install v4.1.9 for some reason, try:

Code:
$ composer create-project codeigniter4/appstarter:4.1.9 pr


Thanks, @kenjis I was confused with the version I thought it is 4.1.2 oh dear me that I didn't know that it was a new version (4.2) oh dear me

I am sorry all guys I was really confused between this version (4.1.2) and I didn't know that there is a new CI 4.2 at last from my hearsay I expect to see a new CI version 5 that was stuck in my brain
Do Codeigniter Before Do You!
yekrinaDigitals

Reply
#8

(This post was last modified: 06-09-2022, 07:15 AM by murugappan.)

(06-06-2022, 07:20 PM)luckmoshy Wrote:
(06-06-2022, 06:06 PM)datamweb Wrote: @luckmoshy  The latest version released is now 4.2(See)
That's why you get it.
If you want to get the previous version(4.1.9) use:

Code:
composer create-project codeigniter4/appstarter:4.1.9 pr


Thank you @datamweb because before I used that way and I got it right but I then try and got 4.2 so I was surprised why it gives me 4.2! ok any way thank you

(06-06-2022, 03:10 PM)kenjis Wrote: If you need to install v4.1.9 for some reason, try:

Code:
$ composer create-project codeigniter4/appstarter:4.1.9 pr


Thanks, @kenjis I was confused with the version I thought it is 4.1.2 oh dear me that I didn't know that it was a new version (4.2) oh dear me

I am sorry all guys I was really confused between this version (4.1.2) and I didn't know that there is a new CI 4.2 at last from my hearsay I expect to see a new CI version 5 that was stuck in my brain

Hi i tried the composer code  for version 4.1.9 but did not work. The installation was incomplete. It gives me this error:


Code:
[b]Fatal error[/b]: Uncaught Error: Call to a member function run() on int in C:\xampp\htdocs\MyCoursesLG\testbed\pr\index.php:37 Stack trace: #0 {main} thrown in [b]C:\xampp\htdocs\MyCoursesLG\testbed\pr\index.php[/b] on line [b]37[/b]

Even the spark does not work. I get this error :

Code:
Fatal error: Uncaught TypeError: Argument 1 passed to CodeIgniter\CLI\Console::__construct() must be an instance of CodeIgniter\CodeIgniter, int given, called in C:\xampp\htdocs\MyCoursesLG\testbed\pr\spark on line 48 and defined in C:\xampp\htdocs\MyCoursesLG\testbed\pr\vendor\codeigniter4\framework\system\CLI\Console.php:29
Stack trace:
#0 C:\xampp\htdocs\MyCoursesLG\testbed\pr\spark(48): CodeIgniter\CLI\Console->__construct(1)
#1 {main}
  thrown in C:\xampp\htdocs\MyCoursesLG\testbed\pr\vendor\codeigniter4\framework\system\CLI\Console.php on line 29 


I am using php 7.4 under xampp in windows 10. Please help. Thank you.
Reply
#9

open composer.json and in section "require" specify version 4.1.9
and then composer update

2Team: For the appstarter, you need to specify the version of the framework statically, for each release.
"^4" = install the latest version.
Reply
#10

@murugappan
Please read the User Guide.
https://codeigniter4.github.io/CodeIgnit...le-changes
Reply




Theme © iAndrew 2016 - Forum software by © MyBB