Welcome Guest, Not a member yet? Register   Sign In
PHP serve error
#1

(This post was last modified: 09-22-2022, 10:21 PM by chericrystal.)

Hello Team, I'm Cheri, JR PHP developer, and am working on a PHP project using the new version of codeigniter4. I'm facing some issues on my Cv Writing Service UK website on the page of Signup. However am having an issue with the PHP on OpenSUSE tumbleweed, has anyone attempted a comparable task using OpenSUSE?

I tried several recommendations from stack overflow but none got it working,
ERROT:

[email protected]:/opt/lampp/htdocs/testing/ci-news> php spark serve
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: /usr/lib64/php8/exte
nsions/intl (/usr/lib64/php8/extensions/intl: cannot open shared object file: No such file or
directory), /usr/lib64/php8/extensions/intl.so (/usr/lib64/php8/extensions/intl.so: cannot o
pen shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  require(/opt/lampp/htdocs/testing/ci-news/app/Config/../../vendor/codeigniter4/
framework/system/bootstrap.php): Failed to open stream: No such file or directory in /opt/lam
pp/htdocs/testing/ci-news/spark on line 63

Warning: require(/opt/lampp/htdocs/testing/ci-news/app/Config/../../vendor/codeigniter4/frame
work/system/bootstrap.php): Failed to open stream: No such file or directory in /opt/lampp/ht
docs/testing/ci-news/spark on line 63
PHP Fatal error:  Uncaught Error: Failed opening required '/opt/lampp/htdocs/testing/ci-news/
app/Config/../../vendor/codeigniter4/framework/system/bootstrap.php' (include_path='.:/usr/sh
are/php8:/usr/share/php/PEAR') in /opt/lampp/htdocs/testing/ci-news/spark:63
Stack trace:
#0 {main}
thrown in /opt/lampp/htdocs/testing/ci-news/spark on line 63

Fatal error: Uncaught Error: Failed opening required '/opt/lampp/htdocs/testing/ci-news/app/C
onfig/../../vendor/codeigniter4/framework/system/bootstrap.php' (include_path='.:/usr/share/p
hp8:/usr/share/php/PEAR') in /opt/lampp/htdocs/testing/ci-news/spark:63
Stack trace:
#0 {main}
thrown in /opt/lampp/htdocs/testing/ci-news/spark on line 63
[email protected]:/opt/lampp/htdocs/testing/ci-news> 

4/php8/extensions/intl.so (/usr/lib64/php8/extensions/intl.so: cannot open shared object file
ile or directory)) in Unknown on line 0
Reply
#2

(This post was last modified: 09-22-2022, 10:40 AM by captain-sensible. Edit Reason: clarified xampp )

OpenSuse tumbleweed is a "rolling release " i believe of OpenSuse

"I use Arch by the way" couldn't resist that , and you will know the injoke since your a Linux user.

If i have a look at /etc/php/php.ini around line 930 i have :

Code:
;extension=iconv
;extension=imap
extension=intl
;extension=ldap
extension=mysqli
;extension=odbc

extension=intl IS uncommented so i have use of it.


Now apache will refer to /etc/php/php.ini since apche is "installed" and /etc/php/php.ini is part of the Arch OS.

xampp version of Lampp is a different kettle of fish. Its not installed in the true sense , and is usually put in /opt


if your using xampp , since its basically an embedded system; you have to find and edit the php.ini of Lampp . Since to my knowlede lampp uses is own embedded configs
I use Arch Linux by the way 

CMS in Action
Reply




Theme © iAndrew 2016 - Forum software by © MyBB