Welcome Guest, Not a member yet? Register   Sign In
ETA on CI3 PHP8.2 support?
#21

(02-10-2024, 01:27 PM)kenjis Wrote: It seems that there are some people who are forking privately, so I think there is a way to cooperate with them.

There is also at least one person who is publicly forking.
https://packagist.org/packages/pocketarc/codeigniter

Thanks, I will look into this. Seems gxgpet is still working on CI3 even as of today. But I don't know when the changes will be released. Does he frequent these forums?
Reply
#22

No.
Last Visit:12-17-2020, 11:43 PM
https://forum.codeigniter.com/member.php...e&uid=8604

But yes, he is working on CI3, and is the last maintainer of CI3.
Reply
#23

Great news! I am willing to upgrade my old projects, but I am not willing to migrate them to CI4.
Reply
#24

There seems to be some incompatibilities in pocketarc/codeigniter.

Backward compatibility between BCIT/CI 3.1.13 and Pocketarc/CI 3.2.0 · Issue #3 · pocketarc/codeigniter
https://github.com/pocketarc/codeigniter/issues/3
Reply
#25

(02-12-2024, 05:15 PM)kenjis Wrote: There seems to be some incompatibilities in pocketarc/codeigniter.

Backward compatibility between BCIT/CI 3.1.13 and Pocketarc/CI 3.2.0 · Issue #3 · pocketarc/codeigniter
https://github.com/pocketarc/codeigniter/issues/3

Silly question and sorry for my lack of understanding. Isn't it possible to fork the 3.1-stable branch and apply the patches related to PHP 8.2? Rather than fork the develop branch?
Reply
#26

It is not a silly question. Of course it is possible.
But all Pull Requests are (were) made against develop branch.

The 3.1-stable branch is already 1090 commits behind develop.
https://github.com/bcit-ci/CodeIgniter/tree/3.1-stable
There are already many differences between 3.1-stable and develop.

So, applying PRs created for develop to 3.1-stable may cause many conflicts.
These conflicts need to be resolved.
Reply




Theme © iAndrew 2016 - Forum software by © MyBB