Welcome Guest, Not a member yet? Register   Sign In
Having problems with creating a CRUD..
#11

[eluser]ealonw[/eluser]
Hi guys... Im still having the same problem... can anyone give me more insight on what im doing wrong... take a look at the update function and the view thats called...
*************************************8
function update()
{
$this->load->helper('form');
// $id = $this->uri->segment(3);
$query = $this->db->getwhere('usercomment', array('id' => $id));
$data['id'] = $query->result();

if ( count($_POST) > 0 )
{
$this->db->where('id', $id);
$this->db->update('usercomment', $_POST);
redirect('');
}
else
{
$this->load->view('update_contact_view', $data);
}
}
******************************************************

the expected outcome is to grab the mysql data based on the selected EDIT row which it doesnt do it gives me an empty form... See index VIEW below

*******************************************************
<?php
$i = 1;
if ($query->num_rows() > 0):
foreach ($query->result() as $row):
?>
<tr class="&lt;?php if($i%2 == '0'): echo "alt"; else: echo "row"; endif; ?&gt;">

<td class="td-center">&lt;?php echo $row->fname;?&gt;</td>
<td class="td-center">&lt;?php echo $row->lname;?&gt;</td>
<td class="td-center">&lt;?php echo $row->email; ?&gt;</td>
<td class="td-center">&lt;?php echo $row->comment;?&gt;</td>
<td class="td-center"><a href="&lt;?=site_url("contact/update/$row->fname");?&gt;">Edit</a>&nbsp;<a href="&lt;?=site_url("contact/delete/$row->fname");?&gt;">Delete</a></td>
</tr>
&lt;?php
endforeach;
endif;
?&gt;


Messages In This Thread
Having problems with creating a CRUD.. - by El Forum - 06-05-2008, 12:03 PM
Having problems with creating a CRUD.. - by El Forum - 06-05-2008, 12:22 PM
Having problems with creating a CRUD.. - by El Forum - 06-05-2008, 05:14 PM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 11:26 AM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 11:34 AM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 11:38 AM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 11:46 AM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 12:01 PM
Having problems with creating a CRUD.. - by El Forum - 06-06-2008, 12:16 PM
Having problems with creating a CRUD.. - by El Forum - 06-07-2008, 01:58 AM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 12:45 PM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 01:01 PM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 02:22 PM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 02:54 PM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 03:22 PM
Having problems with creating a CRUD.. - by El Forum - 06-10-2008, 03:47 PM
Having problems with creating a CRUD.. - by El Forum - 06-11-2008, 04:50 PM
Having problems with creating a CRUD.. - by El Forum - 06-11-2008, 05:57 PM
Having problems with creating a CRUD.. - by El Forum - 06-12-2008, 10:09 AM
Having problems with creating a CRUD.. - by El Forum - 06-12-2008, 12:33 PM
Having problems with creating a CRUD.. - by El Forum - 06-12-2008, 02:52 PM
Having problems with creating a CRUD.. - by El Forum - 06-12-2008, 08:50 PM



Theme © iAndrew 2016 - Forum software by © MyBB