• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bit of a linux + code question here!

I've got an app which writes csv files to a temporary folder and then allows the user to download them.

I want to move the folder above the webroot (which i have done with the system and application folders)

I have tried putting the folder there but my app can't write to it. I have made my open_basedir none (dedicated server so no worried there) so that the app can access files above itself.

I just get a "cant write xxx.csv" error, i've got the folder set with the same user and group permissions as everything that is within the webroot and the write permissions are 757 (i've also tried 777) to no avail. I've also tried apache:apache and root:root just in case!

Has anyone got any advice they could lend me please?!


Well as i say the directory is the same user and group as the files in the webroot. Root is the owner and group of the parent directory. I'm running this structure:


So my temp folder is here (as well as the system folder):


/var/www/vhosts/domain.com is 755


/var/www/vhosts/domain.com/httpdocs is 750

And this will effect writing into the temp folder which is writeable? Are you sure?

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.