• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Email Not Sending (SMTP)

#11
[eluser]Spir[/eluser]
And by the way if I put

Code:
$this->load->library('email', $config);
then it load sendmail (not smtp) so it doesn't take care of my config at all.

#12
[eluser]nigwoko[/eluser]
Thanks Spir!. Adding '$this->email->set_newline("\r\n");' did the trick.

#13
[eluser]brookerrj[/eluser]
Spir: I know this is quite a time later but I had the same issue.

I believe that the real cause is using single quotes around the \r\n. Using PHP double quotes evaluate variables and control characters (e.g. \n or \r), whereas single quotes do not.

Where you are setting up the config array you are using single quotes:

Code:
$config['crlf'] = '\r\n';

It should be double quotes:

Code:
$config['crlf'] = "\r\n";

#14
[eluser]malkabani[/eluser]
hi all
now what is the correct solution

#15
[eluser]Unknown[/eluser]
Hello... Today after research so mucho and spend all the day... I'm hosting with justhost, and It's seem that the hosting make you to write the mail with a valid mail from the domain... check the way to config a client from your mail server and that's it

my domain is xinerk.net

$config['protocol']='smtp';
$config['smtp_host']='mail.xinerk.net';
$config['smtp_port']='26';
$config['smtp_user']='[email protected]';
$config['smtp_pass']='L1fq...';
$config['validate'] = 'false';
$config['wordwrap'] = TRUE;
$config['mailtype']="html";
$config['charset']='utf-8';
$config['newline']="\r\n";
$config['alt_message']="Mensaje de SiSP";
$config['crlf'] = "\r\n";
$config['newline'] = "\r\n";
$config['smtp_timeout']='30';


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.