• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Paypal_lib Success Page Problem

#11
[eluser]Jesse Schutt[/eluser]
Good to know!

#12
[eluser]Jesse Schutt[/eluser]
Hey guys,

How do I grab one of the values in the array? I have been using

Code:
Thank You <?php echo $_POST['first_name']; ?>

or

Code:
Thank You <?php echo $this->input->post('first_name'); ?>

but it is just returning "1" instead of the name of the purchaser.

Thanks in advance!

#13
[eluser]spheroid[/eluser]
@jschutt: You might try modifying the config.php as in this post: http://ellislab.com/forums/viewthread/53437/P15/

#14
[eluser]Jesse Schutt[/eluser]
This is really puzzling me. I'm sure it's something simple...

Code:
<? if($_POST): ?>
<p>Here is its information:</p>
<p><code>
&lt;?php    
    foreach ($_POST as $key => $value)
        echo '<strong>'. $key .'</strong>:'. $this->input->post($key) .' <br/>';
?&gt;
</code></p>
&lt;?php endif; ?&gt;

That returns the entire array of from the $_POST array. But when I try to access one of the values with the code from #11 above, it just returns the number 1. Why won't it return the value that shows from the entire $_POST array?

#15
[eluser]Jesse Schutt[/eluser]
Now maybe someone can explain this to me. If I use this code

Code:
&lt;?php $first_name = $_POST['first_name']; ?&gt;
<p>Thank You &lt;?php echo $first_name; ?&gt;</p>

I get "Thank You 1" on the page.

However, if I use this code
Code:
&lt;?php $first_name = $_POST['first_name'];
echo "Thank You ".$first_name; ?&gt;

then it prints out "Thank You April". Is there something wrong with the way I've set the variable in the first example?

Thanks very much!

Jesse

#16
[eluser]Jesse Schutt[/eluser]
Well I'm not certain what is going on here (as if you couldn't tell :red: ) but it appears to be working correctly now. Sorry for clogging up the board.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.