• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
404 regardless... [SOLVED]

#1
[eluser]iainco[/eluser]
Hey guys, I've just uploaded my project to my live server and cannot for the life of me get it going.

I'm getting a CI 404 error message when using this url

http://www.domain.com/beta/index.php/betarel/index

and

http://www.domain.com/beta/index.php


Relevant settings are:

Code:
$config['base_url'] = "http://www.domain.com/beta/";

$config['index_page'] = "index.php";

$config['uri_protocol']    = "AUTO";

$config['url_suffix'] = "";


$route['default_controller']  = 'betarel';

I don't have an htaccess file present.

I have tried all the other options for "uri_protocol", all with the same result.

My default controller code:

Code:
class Betarel extends Base_Controller
{
    function __construct()
    {
        parent::__construct();
        
        if($this->session->userdata('beta') || $this->session->userdata('ID'))
        {
            redirect('home');
        }
    }

    function index()
    {
        $this->load->view('beta');
    }
}
?>


I have my subclass_prefix set correctly.

The project was working perfect on my local machine.

Anything obvious I've missed?

Thanks a lot

#2
[eluser]iainco[/eluser]
I should add that my dir setup is like so

httpdocs/beta
httpdocs/beta/index.php
httpdocs/beta/system/
httpdocs/beta/system/application

and in my index.php the path names are set as follows:

Code:
$system_folder = "system";

$application_folder = "application";

#3
[eluser]iainco[/eluser]
Hate to do this, but does anyone have any idea what may be going wrong? Thanks

#4
[eluser]phpserver[/eluser]
Maybe your server is generating new .htaccess files.You have to investigate what is causing it,if my theory is correct.I heard someone call it .htaccess being generated and deployed on demand(i guess this is how your server responds to new threats,in some small way,i guess)

#5
[eluser]sophistry[/eluser]
are you using routes?

#6
[eluser]iainco[/eluser]
Thanks for your replies guys.

I'm not using any routes sophistry.

I'm going to try out what this post says:

http://ellislab.com/forums/viewthread/44894/

Will report back later.

#7
[eluser]sophistry[/eluser]
you must have a default route set. what is that set to?

#8
[eluser]iainco[/eluser]
Sorry, yup I've got the default controller set to

Code:
$route['default_controller'] = 'betarel';

Everything was working fine on my local machine so it must be a server configuration problem.

#9
[eluser]sophistry[/eluser]
so, i guess you are using dreamhost? that thread you linked to has information about htaccess but you said you are not using htaccess.

just as a test put a normal (not CI) php file called test.php right at your httpdocs root and see if it gets served.

#10
[eluser]iainco[/eluser]
http://www.domain.com/beta/test.php is working fine with

Code:
<?php
phpinfo();
?>

I'm not using dreamhost, it's a private server on fasthosts (I think it's fasthosts).


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.