setting project on Ubuntu 8.04

#1
[eluser]Yogesh[/eluser]
Hi,

I am new to Linux. I am currently using Ubuntu 8.04.
But did not have any idea of how to setup the project in Ubuntu 8.04
I did have setup of php mysql and that is working properly
I am using CodeIgniter.
I just have copied all the data to /var/www/myproject
but it gives some sharing error.
please help me out ! I need this urgent

Thanks in Advance

#2
[eluser]moodh[/eluser]
"some sharing error"?
Do you want us to guess, magically wave a wand to figure out which error? :/
If it's urgent you should give as much details as possible so followup questions like this isn't needed.

#3
[eluser]Yogesh[/eluser]
Actually I have posted this question from other computer, so I did not mentioned the exact error Sorry for that !
Here is the error

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Fatal error: Unknown: Failed opening required '/var/www/springboard/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0


This project is working properly on windows XP machine.

#4
[eluser]Michael Wales[/eluser]
Prob. need to change the permissions on /var/www/ and give the user that is running PHP access.

#5
[eluser]Yogesh[/eluser]
I have set the permission to the folders /var , /var/www and /var/www/springboard (springboard is the project directory) from root user and it shows permission in user login as the create and delete the file in this folder . I also have share the folder /var/www from properties share tab but it did't ask any thing after I click share button but it shows the same error as it shows before is there ant issue of apache configuration setting.
Also one more important thing i forgot to mentioned is
Project also not running from the Root user login gives the same error

I have run the following command
sudo a2enmod rewriteD
sudo a2enmod userdir

but still it shows the same error

#6
[eluser]Yogesh[/eluser]
[quote author="Michael Wales" date="1233401996"]Prob. need to change the permissions on /var/www/ and give the user that is running PHP access.[/quote]

Thank you very much !!! Michael Wales

Now everything is perfectly working after setting the permission
command I used chmod -R 777 /var/www/springboard
Earlier I used GUI mode to set the permission. I am setting the permission in wrong way. I have set the permission to the folders for /var/www/ and var/www/springboard but these permissions are not getting set to the internal folders and files. But my colleague had helped me out for these commands as she is on leave I could not get her help.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.