• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Database Connection Problem

#11
[eluser]TheFuzzy0ne[/eluser]
You could try checking the file permissions.

#12
[eluser]macleodjb[/eluser]
file permissions are ok. I checked to see if mod_rewrite was enabled and it was. I will get a 404 error even if i do this http://localhost/index.php/search. Any ideas?

i get this message.
Code:
Not Found

The requested URL /search was not found on this server.

#13
[eluser]pistolPete[/eluser]
Are you using a .htaccess file?

#14
[eluser]TheFuzzy0ne[/eluser]
It sounds like you don't have the index.php file in the root of your Web directory. I know it sounds silly, but did you copy it over? If Apache says the file isn't there, there's a pretty good chance it isn't there, or it's the permissions. I can't think of anything else it might be.

#15
[eluser]macleodjb[/eluser]
yes i am using a .htaccess file.

my front end controller works fine, it just seems to be all the other controllers. for instance http://localhost/index.php works fine. Anything outside of this doesn't work

#16
[eluser]TheFuzzy0ne[/eluser]
Try changing $config['uri_protocol'] in the config.php from:
Code:
$config['uri_protocol']    = "AUTO";
to
Code:
$config['uri_protocol']    = "REQUEST_URI";

#17
[eluser]macleodjb[/eluser]
no luck. I had it set to REQUEST_URI already, it wouldn't work on my linux server on AUTO. I tried making my base_url c:/web/ where it resides but that was unsuccessful as well. Since i already had one configuration issue with my local server settings can you think of any other server setting that might cause this. Outside of CI.

#18
[eluser]TheFuzzy0ne[/eluser]
Off the top of my head, no. Sorry. I will continue to think about it though. It's a very bizarre problem, but no doubt has a insanely simple answer.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.