I choose SMTP, but get mail() error

#21
[eluser]nunomira[/eluser]
In my tests I have also got a lot of errors, depending on the server and on what was missing.

Here are some errors for future reference:

Quote:451 See http://pobox.com/~djb/docs/smtplf.html.
The following SMTP error was encountered: 451 See http://pobox.com/~djb/docs/smtplf.html.
Unable to send email using PHP SMTP. Your server might not be configured to send mail using this method.


Quote:Severity: Warning
Message: mail() [function.mail]: SMTP server response: 502 negative vibes
Filename: libraries/Email.php
Line Number: 1553


Quote:Unable to send email using PHP mail(). Your server might not be configured to send mail using this method.


Quote:Severity: Warning
Message: mail() [function.mail]: SMTP server response: 503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.
Filename: libraries/Email.php
Line Number: 1553



Quote:Fatal error: Maximum execution time of ...


I was astonished to find out that two different servers (unix and windows) didn't allow me to send email because
Code:
$config['newline'] = "\r\n";
was missing from the configuration file email.php.


#22
[eluser]nunomira[/eluser]
So, with:

- a SMTP server
- the right credentials
- the correct configuration email.php file
- the newline parameter defined as above

I was able to send emails from my local PHP installation, using Wampserver on Windows 7.

No need to:
- edit anything in php.ini
- use ini_set()

#23
[eluser]Unknown[/eluser]
[quote author="nunomira" date="1328273673"]In my tests I have also got a lot of errors, depending on the server and on what was missing.

Here are some errors for future reference:

Quote:451 See http://pobox.com/~djb/docs/smtplf.html.
The following SMTP error was encountered: 451 See http://pobox.com/~djb/docs/smtplf.html.
Unable to send email using PHP SMTP. Your server might not be configured to send mail using this method.


Quote:Severity: Warning
Message: mail() [function.mail]: SMTP server response: 502 negative vibes
Filename: libraries/Email.php
Line Number: 1553


Quote:Unable to send email using PHP mail(). Your server might not be configured to send mail using this method.


Quote:Severity: Warning
Message: mail() [function.mail]: SMTP server response: 503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.
Filename: libraries/Email.php
Line Number: 1553



Quote:Fatal error: Maximum execution time of ...


I was astonished to find out that two different servers (unix and windows) didn't allow me to send email because
Code:
$config['newline'] = "\r\n";
was missing from the configuration file email.php.

[/quote]


Yes, this!!!

I was having errors with the Communicate module in EE 1.7x; Running on a Windows server.

Needed to change system>core>core.email.php so that

var $newline = "\r\n";
var $crlf = "\r\n";

Now the mail is sent.

#24
[eluser]InsiteFX[/eluser]
The reason you are all having this problem, is because the smtp settings are in your php.ini file.

php.ini
Code:
[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = smtp.comcast.net
; http://php.net/smtp-port
smtp_port = 25


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.