• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
unable to load uri

#1
[eluser]kalpesh[/eluser]
hi,
I am getting strange error in my application.
I try to load uri library but it is giving error like this:
Code:
An Error Was Encountered
Unable to load the requested class: uri

It works in localhost perfectly but on shared web hosting it is giving me this error
Please help me
Thanks in advance.

#2
[eluser]pistolPete[/eluser]
Read the user guide: user_guide/libraries/uri.html

Quote:Note: This class is initialized automatically by the system so there is no need to do it manually.

#3
[eluser]kalpesh[/eluser]
thanks i solved the error.
But when i try to work on with pagination.
It gives me strange result when page links shown.
If there are 40 records in page and 5 records in each page then it has to show like this
1 2 3 4 5 6 7 8 > Last>
But it is showing
1 2 3 > Last>

and also when i click on links it always show current page 1 but the contents on page changes.

#4
[eluser]valajbeg[/eluser]
[quote author="kalpesh" date="1239467734"]thanks i solved the error.
But when i try to work on with pagination.
It gives me strange result when page links shown.
If there are 40 records in page and 5 records in each page then it has to show like this
1 2 3 4 5 6 7 8 > Last>
But it is showing
1 2 3 > Last>

and also when i click on links it always show current page 1 but the contents on page changes.[/quote]

i have same problem

it seems that uri library doesn't load automatically and i can't load it explicitly.

What you did to solve this problem?

#5
[eluser]kalpesh[/eluser]
uri library load automatically.
You doesn't have to do anything.
Just use it like this :
$this->uri->segment(3);


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.