• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FreakAuth isValidUser( ) problem

#1
[eluser]Unknown[/eluser]
I have installed FreakAuth on my website and everything appears to be working. I use the isValidUser method to print a different menu for users that are logged in. This happens on every page that is displayed.

Whenever I login and navigate to any page within the website three times, the isValidUser method is no longer returning true and therefore shows the default menu.

My menu code looks like this:

Code:
<ul>
    <li>&lt;?=anchor('home', 'Home')?&gt;</li>
    &lt;?php if (isValidUser()) { ?&gt;
        <li>&lt;?=anchor($this->config->item('FAL_changePassword_uri'), 'Manage')?&gt;</li>
    &lt;?php } else { ?&gt;
        <li>&lt;?=anchor($this->config->item('FAL_register_uri'), 'Register')?&gt;</li>
    &lt;?php } ?&gt;
</ul>

#2
[eluser]Grahack[/eluser]
Hi, I did have this similar problem at the very beginning. I have no answer, I reinstalled my app starting with FAL and everything was fine.

This session being lost after several clicks is still a mystery.

#3
[eluser]I666I[/eluser]
I was having the same problem here. I loaded FA into an existing app, and everytime I would log in, after exactly 3 clicks / 3 presses / 3 navigation / 3 buttons (being verbose for search in case others have same issue).

It seems like the problem was autoloading. I deleted cookie helper, and session library from autoload.php and it cleared up the problem.

HTH


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.