Welcome Guest, Not a member yet? Register   Sign In
404 Not Found - sure it's simple but can't figure it out

[eluser]Chad Fulton[/eluser]
Which type of 4040 Not Found screen are you getting? Is it the one you get if you go to http://this-webpage-does-not-exist.com, or is it a CodeIgniter one?

Yeah, what Chad said ^^, and I should have added these to the list of links to try pasting into your browser:


I think you mentioned the index function is working when clicked in the browser, so that would imply that something's up and running locally.

Keep trying stuff. Wink

It's the browser standard 404 page, not the CI one.

Typing this:


in the browser address bar takes me to the index function in the controller and shows me the view associated with that function.

[eluser]Chad Fulton[/eluser]
Since it's the standard 404 page, it must a problem with your .htaccess configuration. Essentially, the page request isn't even making it to CodeIgniter.

Is that all you have in the .htaccess file?

Here's my .htaccess file - it sits in the "ci" folder:

RewriteEngine on
RewriteCond $1 !^(index\.php|images|captcha|css|js|robots\.txt)
RewriteRule ^(.*)$ index.php/$1 [L]


[eluser]Chad Fulton[/eluser]
My guess is that this is a problem with your webserver. Since you mentioned localhost, I assume you're running Apache webserver on your computer. If that's the case, then I think this might do the trick:

Go to wherever you installed Apache (C:\Program Files\Apache Software Foundation\Apache2.2 maybe?) and go to the conf folder. Edit httpd.conf.

Where it says

# This should be changed to whatever you set DocumentRoot to.
<Directory "path/to/your/document/root/here">
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    Options Indexes FollowSymLinks

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    AllowOverride None

    # Controls who can get stuff from this server.
    Order allow,deny
    Allow from all


you're going to want to change "AllowOverride None" to "AllowOverride All"

Hi Chad,

you're a genius!

I am indeed running a local wamp-type setup.

changing the AllowOverride to All makes the differecne.

It works!

Thanks again.

Theme © iAndrew 2016 - Forum software by © MyBB