• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multilanguage CI with db_prefix

#1
[eluser]Unknown[/eluser]
Hello all,
because this is my first post in the forum, I would like to say a big 'Great Job' to the creators of this great miracle "Codeigniter". I use it for nearly half a year and so far I have not met a problem that can not handle. Most were from my ignorance and lack of CI.

But now for the first time I need help from the big guru in the forum Smile

Here's what my situation.

Working on multilanguage application based on the CI of courseSmile) I have problems when I use different DB groups with dbprefix. But I have the following problems.

When load the database library autoload.php in my application config dir and then a model I want to use another group: for example $ this-> load-> database ( 'en', TRUE); can not find my table: en_pages example. and says that it is a table pages must seek table en_pages. If in the default group set db_prefix 'default_' when load group 'en' says that it can not find taablitsa 'default_pages' and is expected to seek table' en_pages'. However, when this procedure is to be loaded without a database library in autoload.php in my application config everything works correctly. If anyone has an idea what is actually happening and what is wrong will be happy if you can give me direction or give me a slap and beat two to sanctify me.

Sorry about my English.

Marian


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.