• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot Load Controller

#1
[eluser]frozenmaiden[/eluser]
Hi all..

I developed site with codeigniter framework, but i face a strange problem

When i upload my site into hosting,it just produce a blank screen,please help me because

the deadline is one weeks again.

the website url is http://worldwaterball.com/test/

my .htaccess

Code:
RewriteEngine On
RewriteBase /test/
RewriteCond $1 !^(index\.php|images|robots\.txt|css|js|style.css|rabbit-assets|files|modules|assets|managedb)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /test/index.php/$1 [L]

My uri_protocol

Code:
$config['uri_protocol']    = "AUTO";

I didn't understand why it can be happen,because it work when i host it on different server.. :down:

I'm from indonesia,Sorry for my bad english..

#2
[eluser]imn.codeartist[/eluser]
what is the php version of your server ?

#3
[eluser]bitist[/eluser]
Probably you have some errors and the server doesn't configured to display error messages.
Try to add this to .htaccess to see the eventually errors:

Code:
php_value display_errors 1
php_value error_reporting 2039

#4
[eluser]frozenmaiden[/eluser]
[quote author="dixcoder" date="1256029174"]what is the php version of your server ?[/quote]

My PHP Version was 4.3.9

Code:
php_value display_errors 1
php_value error_reporting 2039

i already try to add that code on my .htaccess, but it produce "500 Internal Server Error"

please help me to solve this problem..

#5
[eluser]frozenmaiden[/eluser]
i try to debug and then the code stopped on system/codeigniter/CodeIgniter.php line 154

Code:
include(APPPATH.'controllers/'.$RTR->fetch_directory().$RTR->fetch_class().EXT);

but i still didn't understand why it can be happen, because on another server it running perfectly.

>.<

anybody help me plz..

#6
[eluser]bitist[/eluser]
Maybe .htaccess is not allowed to set and that produce “500 Internal Server Error”.
You should try to activate error display in php.ini (if allowed).
Create a php.ini in your root folder and add these lines:

Quote:display_errors = On
error_reporting = E_ALL & ~E_NOTICE

#7
[eluser]frozenmaiden[/eluser]
i tested your suggestion,but no error found. it just display white blank page (http://www.worldwaterball.com/test/)

#8
[eluser]bitist[/eluser]
Has your log directory write permission? If not try chmod 777 the log directory.

#9
[eluser]frozenmaiden[/eluser]
if you mean is my logs folder under codeigniter system folder, i already grant it with write permission. I read the log report but didn't find anything..

#10
[eluser]clip[/eluser]
Try changing $config['uri_protocol'] = "AUTO"; to one of the other options, I have had trouble using "AUTO" in the past.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.