Using HTML 4.01 ?

#1
[eluser]Diti[/eluser]
Hi guys,

For particular reasons, I want to make my website in HTML 4.01.
However, I'd like to use, for instance, the form helper.

You should know that the main difference between HTML and XHTML is the way to write the closing tag.
Code:
<!-- In HTML -->
<img src="" alt="">

&lt;!-- In XHTML --&gt;
<img src="" alt="" />
And so, the form generated by the form helper is XHTML-based.

Am I forced to modify myself CI internal code or there is another way ?
Thanks for you attention.

Regards,

Diti.

#2
[eluser]joeles[/eluser]
If you copy the form helper file to application/helpers/form_helper.php, CI will use that file instead of the one located in system/helpers. You can then modify your copy in the application/helpers folder to be HTML 4 without affecting the CI core code.

#3
[eluser]Diti[/eluser]
Thank you very much joeles, I didn't know that manipulation Smile .

Diti.

#4
[eluser]Derek Allard[/eluser]
I just wrote Giving your Helpers a little Help 4 days ago - funny how that works Wink

#5
[eluser]Michael Wales[/eluser]
Haha - I was just reading that article Derek. Your blog is definitely a great resource - and the application specific helpers are a great tool.

To Diti: If you are wanting to use the form helpers, definitely go this route. Personally, I only use form_open() and for_close() - I prefer to markup the form myself - just personal preference though.

#6
[eluser]Diti[/eluser]
Perfect, even if this article is too long for my brain translation capacity :p
I plan to write a little french book for improve myself in LaTeX.

To walesmd : In fact, I just want to (try to) improve my productivity.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.