• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem removing index.php - I just get the homepage all the time...?


I've just launched our new site, however I can't get it to redirect correcly when I remove the index.php file in .htaccess

When I click to visit one of the controller pages, I just get the homepage instead. The URL shows correctly I.e.

But it's just the homepage...

Has anyone run into this problem before?

It worked just fine when I was running it off a temporary URL, i.e.

But when I run it off the top level domain name, it just shows the homepage all the time...


After a lot of trial and error I *think* and hope I've fixed it.

Edited config.php and changed the uri_protocol from AUTO to $config['uri_protocol'] = "ORIG_PATH_INFO";

Weird but I'm happy as our new site is looking good!

just remove "/" before index.php
like this:

RewriteEngine on
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteRule ^(.*)$ index.php/$1 [L]

Thanks, pretty sure I tried that... Issue is also confused slightly as I had other .htaccess stuff in there too. I think it must just be a weird server setup though as it was all working fine on my local wamp server. Thanks anyway, I'll know for next time to try those other config settings sooner.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.