php5 ?

#1
[eluser]Unknown[/eluser]
Hi All,

I'm new to CI and I'm trying to understand just how much "support" CI has for php5.

In the "Code Igniter at a Glance" portion of the documentation I read this:
"Note: CodeIgniter will run on PHP 5. It simply does not take advantage of any native features that are only available in that version."

But in the CI 1.7.2 release notes I read this:
"Compatible with PHP 5.3.0"

Can someone tell me what "compatible" means in CI terms? Does it support all the features or does it just work?

#2
[eluser]Jelmer[/eluser]
In it's core CI doesn't utilize much PHP5 functionality, though a very small portion will (Base5.php in the system/codeigniter dir).

While CI doesn't use PHP5 natively, that won't stop you from using PHP5 when programming in CI. There's a couple of topics on extending CI functionality to utilize some of the functionality PHP5 provides, search the forums for those if you're interested.

CI does support PHP5 and is fully compatible, that means it will run on PHP5 (up to 5.3 at the moment as you mentioned) without any errors. That also means that it won't utilize PHP5 only functionality and it still means you're free to use whatever PHP5 functionality you want.

#3
[eluser]cahva[/eluser]
There were lots of changes from PHP version 5.2 -> 5.3. Some of those changes(like removing deprecated functions etc.) made CI not to work with PHP 5.3. Lots of hosts use still PHP 5.2.x on their servers because 5.3 "broke" lots of old apps.

CI itself doesnt take advantage of PHP 5, but that does not mean that you cant.

#4
[eluser]Unknown[/eluser]
Ah...Thank you both!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.