Problem loading custom library

#11
[eluser]frost9928[/eluser]
[quote author="ranjeet_sangle" date="1271411847"]bro you are getting me all wrong ...


I was just saying that you must have loaded the same library more than once...

like
Code:
class Some_controller extends Controller
{function index()
{
$this->load->library('ups');
//some code
$this->load->library('ups');
}//index()
}//class

and there's no problem in calling like $this->load->library('ups','some_other_lib');

Sorry if my suggestion are not worth for you..!![/quote]

No I seriously thought it worked at first but I forgot I still had it autoloading which did actually fix the problem. Once I took it out of autoload array it went back to not working. I don't know what's wrong with it. I made sure I wasn't calling it twice and that it follows the format in the user guide and it just won't work unless I autoload it. Same with the CI database library on my system... absolutely will not work unless it's autoloaded. I think it's just my server trying to give me headache. No matter, it works as an autoloaded library and it doesn't do anything unless I tell it to, so it's not taking any resources to speak of.

Thank you all for your suggestions. Happy coding.

#12
[eluser]luke holder[/eluser]
codeignitor does allow you to load multiple libraries at the same time

$this->load->library('ups,lib2,lib3');

if you are wishing to load the same lib twice give it a unique name

$this->load->library('ups,$params,'ups1');
$this->load->library('ups,$params,'ups2');

$this->ups1->method
$this->ups2->method


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.