• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fckeditor+CI online

#1
[eluser]rurkss[/eluser]
Please, help me. I got this message, after I loaded my site on host
Code:
A PHP Error was encountered

Severity: Warning

Message: include_once(system/application/plugins/fckeditor/fckeditor_php5.php ) [function.include-once]: failed to open stream: No such file or directory

Filename: libraries/fckeditor.php

Line Number: 31
A PHP Error was encountered

Severity: Warning

Message: include_once() [function.include]: Failed opening 'system/application/plugins/fckeditor/fckeditor_php5.php ' for inclusion (include_path='.:/usr/local/php5/lib/php')

Filename: libraries/fckeditor.php

Line Number: 31
A PHP Error was encountered

Severity: Warning

Message: Cannot modify header information - headers already sent by (output started at /home/rafinad/domains/mechty.com.ua/public_html/system/libraries/Exceptions.php:166)

Filename: codeigniter/Common.php

Line Number: 356
On localhost everything is working fine. why i got that message??!!

my config.php file
Code:
$config['fckeditor_basepath'] = "/system/application/plugins/fckeditor/"; // should start with slash

my fckeditor.php file in system/application/libraries/
Code:
if (!defined('BASEPATH')) exit('No direct script access allowed');
....
....
....
if ( !function_exists('version_compare') || version_compare( phpversion(), '5', '<' ) )
    include_once( 'system/application/plugins/fckeditor/fckeditor_php4.php'  ) ;
else
    include_once( 'system/application/plugins/fckeditor/fckeditor_php5.php ' ) ;

#2
[eluser]Jelmer[/eluser]
You got that message because in all likelyhood paths are handled different on your server from your home-PC.

Try changing this:
Code:
if (!defined('BASEPATH')) exit('No direct script access allowed');
....
....
....
if ( !function_exists('version_compare') || version_compare( phpversion(), '5', '<' ) )
    include_once( 'system/application/plugins/fckeditor/fckeditor_php4.php'  ) ;
else
    include_once( 'system/application/plugins/fckeditor/fckeditor_php5.php ' ) ;
To this (note also the space at the end of the PHP5 file):
Code:
if (!defined('BASEPATH')) exit('No direct script access allowed');
....
....
....
if ( !function_exists('version_compare') || version_compare( phpversion(), '5', '<' ) )
    include_once( APPPATH.'plugins/fckeditor/fckeditor_php4.php'  ) ;
else
    include_once( APPPATH.'plugins/fckeditor/fckeditor_php5.php' ) ;

And you might do the same for the other setting. The APPPATH constant should always work when CI works.

#3
[eluser]rurkss[/eluser]
Thanks a lot, you my god!!! its working!!!!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.