• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot load requested file?

#1
[eluser]parham90[/eluser]
Hi all,
I have got a problem that has me confused. In my controller, I have put:

Code:
$this->load->library('recaptcha'); //Load the recaptcha library I have downloaded from the
//wiki.
$data['captcha'] = $this->recaptcha->get_html();

I have verified that:
1. The recaptcha.php file is in my application/libraries folder.
2. Recaptcha.php is capitalized.
3. The class is:

Code:
class Recaptcha {
...

So, what could be wrong here? I don't think setting the .htaccess to rewrite all requests except index.php and images folder is causing this?

Thanks in advance!

#2
[eluser]Narkboy[/eluser]
Are you doing this on your local machine or on a host somewhere?

I just had a nightmare getting models to work correctly on a host after they had been working fine on my local machine. I had to work it out pretty fast but basically it came down to the file name / model name / name of the model called name having different capitalisation. Don't ask me how I fixed it, I just changed everything until it worked because I had no time. CI seems to be very picky about this..

#3
[eluser]LuckyFella73[/eluser]
Do you get an error message? Would be helpfull to know where your script
stops from running the right way.

A common mistake is to forget to set the right folder permissions (writable)
for the captcha image. Did you check that?

#4
[eluser]Zack Kitzmiller[/eluser]
Blah.. I didn't read all the way through your post.Never mind.

#5
[eluser]parham90[/eluser]
Here is the exact error:

Unable to load the requested file: recaptcha.php

And yes, as I said, I have varified that the file Recaptcha.php is capitalized as the help file suggests.

#6
[eluser]parham90[/eluser]
I was forgetting the recaptcha.php file in views, not in libraries. That was causing the issue. Smile


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.