Obfuscated Email Subject Issue

#11
[eluser]whobutsb[/eluser]
Same thing in my Gmail.
I setup a config file in my config directory called email.php, is that the correct way to name a config file?

Here is the config I have in that:
Code:
$config['useragent']    = 'NHC SurveyForce';
$config['smtp_host']     = '*******';
$config['protocol']     = 'smtp';

$config['smtp_user']    = '*****';
$config['smtp_pass']     = '*******';
$config['smtp_port']     = 25;
$config['mailtype']     = 'html';
$config['newline']        = "\r\n";
$config['crlf']            = "\r\n";
$config['charset']        = "utf-8";

#12
[eluser]WanWizard[/eluser]
Don't see anything wrong with that.

What happens if you do a $this->email->print_debugger() directly after a $this->email->send()? And a var_dump($this->email->_header_str)?

#13
[eluser]whobutsb[/eluser]
For the print_debugger the subject line is still coming across screwed up.

Would it be terrible if I commented out the $subject = $this->_prep_q_encoding($subject); line the CI email library?

#14
[eluser]WanWizard[/eluser]
If that's the case then it looks like your "\r\n" isn't used as newline.

Try
Code:
$this-email->newline  = "\r\n";
before you compose your email.

You could comment it out, it's not a problem as long as your subjects are ASCII characters only. I would advise you to find the problem, instead of working around it (and possibly introduce other issues).

#15
[eluser]whobutsb[/eluser]
No go on just using the $this->email->newline = "\r\n";

Hmm I will keep working on it. Thank you for your help! If anyone else has any ideas, I'd love to hear them!

#16
[eluser]Unknown[/eluser]
I have the same problem when the subject length is longer than 75 characters.

If the subject is longer than 75, the Email Class function _prep_q_encoding add an newline in the subject and then the problem appear.

#17
[eluser]kijla[/eluser]
[quote author="Bluecandy" date="1312733065"]I have the same problem when the subject length is longer than 75 characters.

If the subject is longer than 75, the Email Class function _prep_q_encoding add an newline in the subject and then the problem appear.[/quote]

I had the same problem as you. I changed the value if $crlf from "\r\n" to "\n" in the Email.php file in core/libraries and it seems to be working well now Smile

Code:
var    $newline        = "\r\n";
    var $crlf            = "\n";

#18
[eluser]nikes[/eluser]
I see, but why would it start looking in different ways from if I just create it in directly? Is there any way for me to fix my error?

#19
[eluser]Narf[/eluser]
How does it work with this one guys? https://gist.github.com/3891474

I've been trying to get some feedback on the patch linked here: https://github.com/EllisLab/CodeIgniter/...nt-9330713 ... but as you can see in there - no real-world testers, so I thought I should come here.

#20
[eluser]bclinton[/eluser]
The patched Email.php file worked for me


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.