Some troubles with the default controller

#1
[eluser]Marvin_S[/eluser]
Hey guys,

I have a problem with the default controller. I've just uploaded a project with codeigniter that uses "site" as the default controller. On my localhost it worked perfectly. But now that I've uploaded it it causes the following problem.

When I enter the domain like this:

http://www.domain.com

I get a message "New Web Project Page"

if I enter:

http://www.domain.com/index.php

it works perfectly. Someone knows this problem? I use mod rewrite.

Thanks in advance,
Marvin

#2
[eluser]mddd[/eluser]
Sounds like there is a problem with the rewrite. Did you upload the .htaccess file okay? Some ftp clients hide files that start with a dot (.) !

Also, check that there are no files already in your hosting account on the server. If there is "index.html" file and the server is set to try .html files before .php files, you'll never see the .php file unless you actively call it. So: remove any example files that you don't need from the server.

#3
[eluser]Marvin_S[/eluser]
[quote author="mddd" date="1276722459"]Sounds like there is a problem with the rewrite. Did you upload the .htaccess file okay? Some ftp clients hide files that start with a dot (.) !

Also, check that there are no files already in your hosting account on the server. If there is "index.html" file and the server is set to try .html files before .php files, you'll never see the .php file unless you actively call it. So: remove any example files that you don't need from the server.[/quote]

Gosh, I had an index.html file still in there as you said. Thanks man. I was searching everywhere but not for such a simple thing. Tongue


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.