Welcome Guest, Not a member yet? Register   Sign In
rewrite issue [SOLVED]

So far, the ease of programming in CI and the info on this board makes it easy to solve problems and get apps developed quickly and easily. Now I'm asking for some help. I recently *downgraded* my Ubuntu 10.4 dev system to 9.10. When I did, and restored the project the app won't work. And it has to do with apache re-writing. I think.

I'm currently rewriting the index.php out of the URL, have the index.php entry nulled in the config, and am using request_uri which worked previously.

What's odd is that the home page (default) controller works, but anything else
throws a 404. If I take the error URL and manually insert index.php it works.

I'm stumped.

here's my htaccess:

RewriteEngine on
RewriteBase /
Options FollowSymLinks
RewriteCond $1 !^(index\.php|media|captcha|robots\.txt|) [NC]
RewriteRule ^(.*)$ /index.php/$1 [L]
RewriteRule ^index.php/$ /index.php [L]


[update: after continually searching for a solution
I figured out that I needed to change the Directory directives
from AllowOverride None to All]

Theme © iAndrew 2016 - Forum software by © MyBB