Welcome Guest, Not a member yet? Register   Sign In
GoDaddy hosting 404 issue

[eluser]Juan Velandia[/eluser]
Helly guys, Im working on a website hosted in godaddy.com servers, but for my surprise it doesn't respond well to url's. For example:

404 Page Not Found

where /ci is just the unzipped folder of codeigniter, as you know it should work like this


Have you experienced this? Any Ideas? thanks in advance

You have to enable your ci setup to accept query strings. I had a similar experience but I did some checking with google and solved it but here is a link to start with:


Hope this helps

I had no problems with godaddy. The site on my signature is hosted there.

And I never enabled query strings.

If 'ci' is just your ci installation, and the 404 is thrown by godaddy/apache (so it's not codeigniter's 404), then the problem has nothing to do with codeigniter I think

[eluser]Juan Velandia[/eluser]
Thanks guys, I´ve solved it with this page: http://anon83.wordpress.com/2007/12/11/c...-problems/

I had to make CI accept query strings, It´s not the most elegant solution, but it worked.



>see edited post below<

[quote author="Juan Velandia" date="1277674280"]I had to make CI accept query strings, It´s not the most elegant solution, but it worked.[/quote]

I had the same problem with my GoDaddy hosting account. After looking briefly at that article and doing a little experimentation, I came up with the following solution:

$config['uri_protocol']    = "AUTO";
I tested this line with each of the 4 other options (PATH_INFO, QUERY_STRING, REQUEST_URI, ORIG_PATH_INFO). The latter three options work and PATH_INFO does not.

This seems to conform with what the User Guide states for correcting this problem (see User Guide Troubleshooting Page):
Quote:it might be that your server does not support the PATH_INFO variable
Apparently, CI uses PATH_INFO as the default when it's set to "AUTO" - I guess AUTO doesn't work on GoDaddy solutions? (Or does it even work at all?)

[eluser]Juan Velandia[/eluser]
Nalorin, thanks for your response. I'll check it as soon as I can. As usual I'm on a dead line...

I ended up not having to change the above, but going from:

RewriteRule ^(.*)$ index.php/$1 [L]


RewriteRule ^(.*)$ index.php?/$1 [L] (notice the question mark)

to make the rewriting in my .htaccess file work.

[quote author="frist44" date="1281404736"]RewriteRule ^(.*)$ index.php/$1 [L]
RewriteRule ^(.*)$ index.php?/$1 [L] (notice the question mark)[/quote]

I don't know if doing that forces CodeIgniter to use query strings or not, but if it does, you should know that the config.php file makes this statement about using query strings with CI:

Quote:Please note that some of the helpers won't work as expected when [Query Strings] is enabled, since CodeIgniter is designed primarily to use segment based URLs.

I also don't know if setting 'uri_protocol' to 'QUERY_STRING' affects CI in the same fashion or not. For this reason, I set uri_protocol to ORIG_PATH_INFO.

Theme © iAndrew 2016 - Forum software by © MyBB