error i am receiving

#1
[eluser]Unknown[/eluser]
Code:
Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\ci\system\codeigniter\Common.php on line 130

Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\ci\system\codeigniter\Common.php on line 136
A PHP Error was encountered

Severity: 8192

Message: Function set_magic_quotes_runtime() is deprecated

Filename: codeigniter/CodeIgniter.php

Line Number: 60
A PHP Error was encountered

Severity: 8192

Message: Assigning the return value of new by reference is deprecated

Filename: libraries/Loader.php

Line Number: 255

#2
[eluser]cahva[/eluser]
You're using older version of CI(which doesnt work with PHP 5.3). These errors have been corrected in the recent version.

#3
[eluser]jbrannon[/eluser]
I'm getting the same error, too... I've read several places now about this conflict, and I have gotten the svn trunk version, but it doesn't seem to fix the error at all. Any other suggestions, or is there something I'm missing...?

Note, I -am- completely new to the svn concept, so perhaps it's not the trunk version I should have picked up? Also, if it makes a difference, the previous version I was using was 1.7.2, downloaded just a couple days ago from the main site.

EDIT:: I apologize, I've searched a bit more and it seems there are some solutions posted elsewhere in this forum. Please disregard this, I'll see if I can't get the error to disappear ^_^;

EDIT-EDIT:: Well, I've tried completely uninstalling CI, then restarting fresh with the new trunk, and I still receive the same errors. Again, if anyone can help, it would be appreciated... I would rather fix the error than hide it, if possible.

Running PHP 5.3.3.0, if that helps clear anything up...

#4
[eluser]cahva[/eluser]
SVN has not been used for CI for a long time and they changed version control to Mercurial and CI can be found on Bitbucket. You can dowload the tip(latest) or 1.7.2 branch there. Or just click download on the ci site which gives the latest stable 1.7.2 version (atm).

With version CI 1.7.2 that error should not be there. If you check line 60 of codeigniter/CodeIgniter.php, the set_magic_quotes_runtime is not in that line. If it is, you are running different version.

#5
[eluser]jbrannon[/eluser]
Hmm... Thanks for the information, cahva. I'll see if I can pick a copy up from Bitbucket then. However, I just redownloaded 1.7.2 from the mainsite, and it seems no different than the one I currently have, so the error still seems to be a bit of a mystery to me. Either way, I've decided to try some different scripts instead, so it's not really an issue at the moment! Thanks again, I'll remember this in case it comes up again sometime :3


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.