• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
not loading view[SOLVED]

#11
[eluser]diasansley[/eluser]
The render output.
Code:
function _renderOutput($link, $array)
    {
        $this->content['content'] = $this->parser->parse($link, $array, true);
        $this->renderTemplate();
    }
    
    /**
     * renders main frontend template and outputs it
     */
    function renderTemplate($search_text = null)
    {
        $categories = $this->_categories();
        $news = $this->m_news->selectAll();
        $utilities = $this->m_utilities->selectAll();
           $this->content['menu_navigation']     = $this->parser->parse('layout/_menu_navigation', array('categories' => $categories,'news'=>$news,'search_text'=>$search_text,'utilities'=>$utilities), true);
        $this->parser->parse('layout/default.php', $this->content, false);
    }

#12
[eluser]diasansley[/eluser]
[quote author="takasia" date="1292415598"]You have the
</body>
tag without the start <body> on the begining of the page?
Or is the source not complete?[/quote]


this is only the part that concerns the problem.

Thanks

#13
[eluser]Unknown[/eluser]
Thank, I have same problem

#14
[eluser]tonanbarbarian[/eluser]
ok you have so much going on that it is not possible to diagnose this issue
but what i suspect is that in some of your code somewhere you are changing the $this->content['content'] when you do not expect it

in fact i notice that you have the following
Code:
$this->content['content'] .= $this->_renderFrontendOutput('brands/_front_entry_brands_list.php',array('brands'=>$brands));
but inside renderOutput you do the following
Code:
$this->content['content'] = $this->parser->parse($link, $array, true);

in fact you have supplied the wrong code
you have supplied the _renderOutput method and not _renderFrontendOutput


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.