• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
blank rows in any template? [SOLVED]

#1
[eluser]nevercode[/eluser]
when I look at the codes of my layout
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
&lt;html &gt;&lt;head>

they are on top. but when I look page source I see blank rows

Code:
.





<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
&lt;html &gt;&lt;head>
(. for editor)
I am using Ocular Template Library
* @author Lonnie Ezell
* @version 2.12

I dont have any br s



The problem was about empty spaces at the end of model files. I dunno why library is pasting those empty to layout

#2
[eluser]nevercode[/eluser]
bump.. any ideas why happens this?

#3
[eluser]Glazz[/eluser]
Try encoding the file to UTF-8 without BOM

#4
[eluser]nevercode[/eluser]
all views and php files unix utf8 without BOM my sessions are working fine also . UTF8 chars also normal. but why is there a small blank space. on top 3 or 4 chars long.

#5
[eluser]Glazz[/eluser]
hmm i don't know, but maybe you have any echo left on a controller or model don't know for sure, i never had this issue with CI.

#6
[eluser]nevercode[/eluser]
it has also in error_db in errors everywhere.

#7
[eluser]InsiteFX[/eluser]
Take the space off of your &lt;html &gt;

With out seeing more code it is kind of hard to help you!

InsiteFX

#8
[eluser]nevercode[/eluser]
thanks but it didnt also help. I think it is a Ocular Template Engine Issue

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
&lt;html&gt;&lt;head>
&lt;title&gt;will be title here  - &lt;? if(isset($meta_title)) echo $meta_title;?&gt;&lt;/title&gt;
&lt;meta name="Pragma" content="no-cache"&gt;
&lt;meta http-equiv="cache-control" content="no-cache"&gt;
&lt;meta http-equiv="Pragma" content="no-cache"&gt;
&lt;meta http-equiv="Expires" content="Mon, 26 Jul 1997 05:00:00 GMT"&gt;
&lt;META NAME="description" CONTENT="&lt;? if(isset($meta_descr))
echo $meta_descr; ?&gt;&lt;? if(!isset($meta_descr)){ ?&gt;&lt;? } ?&gt;"&gt;
&lt;META NAME="keywords" CONTENT="&lt;? if(isset($meta_keys)) echo $meta_keys;?&gt;&lt;? if(!isset($meta_keys)){?&gt;&lt;? } ?&gt;"&gt;
&lt;META NAME="generator" CONTENT="w"&gt;
&lt;meta http-equiv="refresh" content="250"&gt;
&lt;meta http-equiv="imagetoolbar" content="no"&gt;
&lt;meta http-equiv="Content-Type" content="text/html; charset=UTF-8"&gt;
&lt;link rel="icon" href="http://www.domainname/favicon.ico" type="image/x-icon"&gt;
&lt;meta name="google-site-verification" content="ii8kjhgWU3r-VJpUNj897nFcYKYmqra9n_VUJD_QI2c"&gt;
[removed][removed]
[removed][removed]
[removed][removed]
[removed][removed]
[removed][removed]

&lt;link href="&lt;?=site_url();?&gt;css/global.css" rel="stylesheet" type="text/css" /&gt;
&lt;link href="&lt;?=site_url();?&gt;css/contentslider.css" rel="stylesheet" type="text/css" /&gt;
&lt;link href="&lt;?=site_url();?&gt;css/jquery-ui-1.8.6.custom.css" rel="stylesheet" type="text/css" /&gt;
&lt;link rel="stylesheet" type="text/css" href="&lt;?=site_url();?&gt;css/jquery.lightbox-0.5.css" media="screen" /&gt;
  
&lt;/head&gt;&lt;body>

this is my application layout code but the same problem I have in 404 or db_error layouts.

#9
[eluser]nevercode[/eluser]
and this is the image of issue


[Image: 1zfq7t0.jpg]

#10
[eluser]InsiteFX[/eluser]
All of your PHP tags are wrong &lt;? should be &lt;?php

Also some are using PHP short tags make sure they are turned on.

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
&lt;html&gt;&lt;head>
&lt;title&gt;will be title here - &lt;?php if(isset($meta_title)) echo $meta_title;?&gt;&lt;/title&gt;
&lt;meta name="Pragma" content="no-cache"&gt;
&lt;meta http-equiv="cache-control" content="no-cache"&gt;
&lt;meta http-equiv="Pragma" content="no-cache"&gt;
&lt;meta http-equiv="Expires" content="Mon, 26 Jul 1997 05:00:00 GMT"&gt;
&lt;META NAME="description" CONTENT="&lt;?php if(isset($meta_descr))
echo $meta_descr; ?&gt;&lt;?php if(!isset($meta_descr)){ ?&gt;&lt;? } ?&gt;"&gt;
&lt;META NAME="keywords" CONTENT="&lt;?php if(isset($meta_keys)) echo $meta_keys;?&gt;&lt;?php if(!isset($meta_keys)){?&gt;&lt;?php } ?&gt;"&gt;
&lt;META NAME="generator" CONTENT="w"&gt;
&lt;meta http-equiv="refresh" content="250"&gt;
&lt;meta http-equiv="imagetoolbar" content="no"&gt;
&lt;meta http-equiv="Content-Type" content="text/html; charset=UTF-8"&gt;
&lt;link rel="icon" href="http://www.domainname/favicon.ico" type="image/x-icon"&gt;
&lt;meta name="google-site-verification" content="ii8kjhgWU3r-VJpUNj897nFcYKYmqra9n_VUJD_QI2c"&gt;
[removed][removed]
[removed][removed]
[removed][removed]
[removed][removed]
[removed][removed]

&lt;link href="&lt;?php echo site_url();?&gt;css/global.css" rel="stylesheet" type="text/css" /&gt;
&lt;link href="&lt;?php echo site_url();?&gt;css/contentslider.css" rel="stylesheet" type="text/css" /&gt;
&lt;link href="&lt;?php echo site_url();?&gt;css/jquery-ui-1.8.6.custom.css" rel="stylesheet" type="text/css" /&gt;
&lt;link rel="stylesheet" type="text/css" href="&lt;?php echo site_url();?&gt;css/jquery.lightbox-0.5.css" media="screen" /&gt;

&lt;/head&gt;&lt;body>

InsiteFX


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.