• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Email sending problem Gmail + CI + Win 7

#1
[eluser]bkarat[/eluser]
Hi !

I am facing a problem while sending mails through gmail. The settings used in email.php is given below. I have similar setting on a XP machine and from there I am able to send mails.

$config['protocol']= "smtp";
$config['charset']= "iso-8859-1";
$config['smtp_host'] = 'ssl://smtp.gmail.com';
$config['smtp_user']= 'my mail id';
$config['smtp_pass'] = 'my password';
$config['wordwrap']= "TRUE";
$config['smtp_port']= "465";
$config['mailtype']= "html";
$config['newline']= "\r\n";
$config['crlf']= "\r\n";


The error msg I am getting is:

Message: fsockopen() [function.fsockopen]: unable to connect to ssl://smtp.gmail.com:465 (Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?)

In php.ini, openssl is enabled. Could it be a problem with my machine or with the 'Win 7 Home Basic' I am using?

Please help.

Regards,
Bala

#2
[eluser]bkarat[/eluser]
Hi !

This is to inform you all that my problem got solved after I installed the latest Window version of Apache with open ssl (httpd-2.2.17-win32-x86-openssl-0.9.8o.msi). I can not definitely say that my earlier Apache version was not corrupted; but after the new version was installed, the email sending through gmail started working fine. But I noticed a strange problem - this latest Apache version doesn't work with the PHP version 5.2.16 (so, I am using my earlier PHP version 5.2.11).

Regards,
Bala


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.