• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Servers running PHP 4.1.2 - Options for adapting CodeIgniter to run?

#1
[eluser]charlieD[/eluser]
I've developed a site and it turns out that for some reason the servers that it will run on are using the ancient PHP 4.1.2. As you may know CodeIgniter requires 4.3.

I don't think upgrading is an option, so I'm now facing removing CodeIgniter and adapting the code in a very short amount of time.

Does anyone have any other suggestion? For example, is there anything that can be done to adapt CodeIgniter to run on this version? At the moment the fatal exception 'undefined function ob_end_flush' is being returned, but there may be other problems after that.

If not, any suggestions on what would be the quickest way of adapting this to run on its own?

I'm using the sessions, validation and database classes, and obviously models, views and controllers...

Any help ASAP greatly appreciated!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.