500 Internal server error - STILL NOT SOLVED!

#1
[eluser]leet_2k[/eluser]
Hi there,
I am trying to work on my wrk teams dev server.I have created a folder called abc under one of the current websites (lets call it http://abcdev.com.au/). Now I placed my CI files in the abc folder..

More info:-
==>
==>http://abcdev.com.au links to a location on server - home/folder1/public_html.
So, the location of abc is - /home/folder1/public_html/abc
==>I have been told that the server is virtual host

Now when I change the base_url to and go to http://abcdev.com.au/abc/index.php, I get the following error:-
---------------
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
============
In my .htaccess file, I have the following:-

Code:
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /home/folder1/public_html

    #Removes access to the system folder by users.
    #Additionally this will allow you to create a System.php controller,
    #previously this would not have been possible.
    #'system' can be replaced if you have renamed your system folder.
    RewriteCond %{REQUEST_URI} ^system.*
    RewriteRule ^(.*)$ /index.php?/$1 [L]
    
    #When your application folder isn't in the system folder
    #This snippet prevents user access to the application folder
    #Submitted by: Fabdrol
    #Rename 'application' to your applications folder name.
    RewriteCond %{REQUEST_URI} ^application.*
    RewriteRule ^(.*)$ /index.php?/$1 [L]

    #Checks to see if the user is attempting to access a valid file,
    #such as an image or css document, if this isn't true it sends the
    #request to index.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

<IfModule !mod_rewrite.c>
    # If we don't have mod_rewrite installed, all 404's
    # can be sent to index.php, and everything works as normal.
    # Submitted by: ElliotHaughin

    ErrorDocument 404 /index.php
</IfModule>  

<VirtualHost *>
        ServerName abcdev.com.au/
        DocumentRoot /home/folder1/public_html/abc
        <Directory /home/folder1/public_html/abc>
                RewriteEngine On
                RewriteBase /
                RewriteCond %{REQUEST_FILENAME} !-f
                RewriteCond %{REQUEST_FILENAME} !-d
                RewriteRule ^(.*)$ index.php/$1 [L]
        </Directory>
</VirtualHost>
============
If I put a .html page and access it thru http://abcdev.com.au/abc/index.html, I get the page.

Please help (Please be clear on the instructions too. Thanks),
leet_2k

#2
[eluser]cideveloper[/eluser]
where is this .htaccess file located? Is it in /home/folder1/public_html or /home/folder1/public_html/abc?

I ask this because your setup from the sounds of it looks like this.

You have a server with an IP address. Many domains are pointing to it thus it is a virtual host setup on apache. One of the domains pointing to it is abcdev.com.au thus you will have a VirtualHost set up in httpd.conf for the domain abcdev.com.au

If the .htaccess is in the /home/folder1/public_html/abc folder you should only need the below

Code:
RewriteEngine on
RewriteCond $1 !^(index\.php|assets|robots\.txt)
RewriteRule ^(.*)$ /abc/index.php/$1 [L]

From the sounds of it you just have a folder in wrk teams dev server main folder.

One last thing. Can you post your config? sometimes there is a glaring problem in that file that may cause this issue.

#3
[eluser]leet_2k[/eluser]
Hi cideveloper (thanks heaps for replying),
Yeah the .htacess file is in the /home/folder1/public_html/abc folder. I have changed it to the following:-

Code:
RewriteEngine on
RewriteCond $1 !^(index\.php|assets|robots\.txt)
RewriteRule ^(.*)$ /abc/index.php/$1 [L]

still no luck...

Following is the config.php file in codeigniter. I haven't chagned anything much except the base_url();

Code:
&lt;?php  if ( ! defined('BASEPATH')) exit('No direct script access allowed');

/*
|--------------------------------------------------------------------------
| Base Site URL
|--------------------------------------------------------------------------
|
| URL to your CodeIgniter root. Typically this will be your base URL,
| WITH a trailing slash:
|
|    http://example.com/
|
*/
$config['base_url']    = "http://abcdev.com.au/ods/";

/*
|--------------------------------------------------------------------------
| Index File
|--------------------------------------------------------------------------
|
| Typically this will be your index.php file, unless you've renamed it to
| something else. If you are using mod_rewrite to remove the page set this
| variable so that it is blank.
|
*/
$config['index_page'] = "";

/*
|--------------------------------------------------------------------------
| URI PROTOCOL
|--------------------------------------------------------------------------
|
| This item determines which server global should be used to retrieve the
| URI string.  The default setting of "AUTO" works for most servers.
| If your links do not seem to work, try one of the other delicious flavors:
|
| 'AUTO'            Default - auto detects
| 'PATH_INFO'        Uses the PATH_INFO
| 'QUERY_STRING'    Uses the QUERY_STRING
| 'REQUEST_URI'        Uses the REQUEST_URI
| 'ORIG_PATH_INFO'    Uses the ORIG_PATH_INFO
|
*/
$config['uri_protocol']    = "AUTO";

/*
|--------------------------------------------------------------------------
| URL suffix
|--------------------------------------------------------------------------
|
| This option allows you to add a suffix to all URLs generated by CodeIgniter.
| For more information please see the user guide:
|
| http://ellislab.com/codeigniter/user-guide/general/urls.html
*/

$config['url_suffix'] = "";

/*
|--------------------------------------------------------------------------
| Default Language
|--------------------------------------------------------------------------
|
| This determines which set of language files should be used. Make sure
| there is an available translation if you intend to use something other
| than english.
|
*/
$config['language']    = "english";

/*
|--------------------------------------------------------------------------
| Default Character Set
|--------------------------------------------------------------------------
|
| This determines which character set is used by default in various methods
| that require a character set to be provided.
|
*/
$config['charset'] = "UTF-8";

/*
|--------------------------------------------------------------------------
| Enable/Disable System Hooks
|--------------------------------------------------------------------------
|
| If you would like to use the "hooks" feature you must enable it by
| setting this variable to TRUE (boolean).  See the user guide for details.
|
*/
$config['enable_hooks'] = FALSE;


/*
|--------------------------------------------------------------------------
| Class Extension Prefix
|--------------------------------------------------------------------------
|
| This item allows you to set the filename/classname prefix when extending
| native libraries.  For more information please see the user guide:
|
| http://ellislab.com/codeigniter/user-guide/general/core_classes.html
| http://ellislab.com/codeigniter/user-guide/general/creating_libraries.html
|
*/
$config['subclass_prefix'] = 'MY_';


/*
|--------------------------------------------------------------------------
| Allowed URL Characters
|--------------------------------------------------------------------------
|
| This lets you specify with a regular expression which characters are permitted
| within your URLs.  When someone tries to submit a URL with disallowed
| characters they will get a warning message.
|
| As a security measure you are STRONGLY encouraged to restrict URLs to
| as few characters as possible.  By default only these are allowed: a-z 0-9~%.:_-
|
| Leave blank to allow all characters -- but only if you are insane.
|
| DO NOT CHANGE THIS UNLESS YOU FULLY UNDERSTAND THE REPERCUSSIONS!!
|
*/
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-';


/*
|--------------------------------------------------------------------------
| Enable Query Strings
|--------------------------------------------------------------------------
|
| By default CodeIgniter uses search-engine friendly segment based URLs:
| example.com/who/what/where/
|
| You can optionally enable standard query string based URLs:
| example.com?who=me&what=something&where=here
|
| Options are: TRUE or FALSE (boolean)
|
| The other items let you set the query string "words" that will
| invoke your controllers and its functions:
| example.com/index.php?c=controller&m=function
|
| Please note that some of the helpers won't work as expected when
| this feature is enabled, since CodeIgniter is designed primarily to
| use segment based URLs.
|
*/
$config['enable_query_strings'] = FALSE;
$config['controller_trigger']     = 'c';
$config['function_trigger']     = 'm';
$config['directory_trigger']     = 'd'; // experimental not currently in use

/*

#4
[eluser]leet_2k[/eluser]
[quote author="cideveloper" date="1296304977"]
From the sounds of it you just have a folder in wrk teams dev server main folder.

One last thing. Can you post your config? sometimes there is a glaring problem in that file that may cause this issue.[/quote]


1) Yep!That's exactly right. I have a folder in wrk teams dev server main folder

2) Done!

#5
[eluser]cideveloper[/eluser]
This may be a stupid question on my part but you have a discrepancy on what you posted here. I assume its just from what you posted as opposed to are actually using.

From .htaccess
Quote:RewriteRule ^(.*)$ /abc/index.php/$1 [L]

From config
Code:
$config['base_url']    = "http://abcdev.com.au/ods/";

you have ods in config and abc in htaccess. Are they the same on your server?

#6
[eluser]leet_2k[/eluser]
Sorry.Thy r sme.Abc is actually ods.I dint wnt to put that in.So i put abc.

#7
[eluser]leet_2k[/eluser]
Sorry.Thy r sme.Abc is actually ods.I dint wnt to put that in.So i put abc.

#8
[eluser]cideveloper[/eluser]
Ok let try this. Inside /home/folder1/public_html/abc folder you probable have your structure looking like this

-index.php
-.htaccess
-system
-application

add test.php inside /home/folder1/public_html/abc and remove the .htaccess file so your folder will look like this

-index.php
-test.php
-system
-application

test.php will be

Code:
&lt;?php

phpinfo();

?&gt;

Now can you get to

1)http://abcdev.com.au/abc/test.php
2)http://abcdev.com.au/abc/index.php

If the answer if yes then put the .htaccess file back in

Now can you get to

1)http://abcdev.com.au/abc/test.php
2)http://abcdev.com.au/abc/index.php

if the answer is no then the problem is with the htaccess file.

#9
[eluser]Unknown[/eluser]
when i run my application downloaded from server. first time i got a 500 internal server error. then a change my base URL in config.php file to localhost. and i allow .htaccess in php.ini.
After these two changes i am getting blank page. there is no error, its showing just a blank page.

Please help me to configure my problem.

#10
[eluser]YahyaKACEM[/eluser]
hi, anyone found a solution to this problem i have the same server error with my codeigniter website, the permissions are 777 and i removed the htaccess file and still no change.
any help, thanx in advance.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.