• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Encryption Class 1.7.2 and 2.0.1

#1
[eluser]Unknown[/eluser]
Hello all,

I'm encrypting some text using the Encryption library (using 2.0.1) and passing it to a another remote server which is running 1.7.2. Are the two encryption methods no compatible? I keep getting a kick back saying the text is unencrypt-able using the same key.

Thanks,
Greg

#2
[eluser]WanWizard[/eluser]
Afaik the code hasn't changed.

What is possible is that one server has the PHP MCrypt extension installed (which CI will use if present), and the other not.

#3
[eluser]Joakal[/eluser]
Not compatible, and only one way. As in; you can use encode_from_legacy()

Step 4: Update stored encrypted data
http://ellislab.com/codeigniter/user-gui...e_200.html

#4
[eluser]WanWizard[/eluser]
He, I missed that one. Good to know, thanks!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.