• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 2.0.2 and compatable libraries

#1
[eluser]Unknown[/eluser]
Hi there,

I've just decided to start using CodeIgniter over CakePHP, but I'm running into some frustrating problems.

Namely which libraries/plugins etc are compatible with CodeIgniter 2.0.2

I've done some research and have tried to use DX auth as my authentication library... which isn't going to work without seriously modifying the code.

So I've now done more research but can't seem to find a way to tell which libraries are compatible and which aren't.

Should I just be using 1.7?

any guidance would be greatly appreciated

#2
[eluser]LuckyFella73[/eluser]
If you need an auth library you should be fine with
Tank_auth or Ion_auth. These two seem to be the most
recommended around these forum - correct me if I'm wrong.
For sure there are others too that might be good for your needs.

Your question "which libraries are CI 2 compatible" is
a bit loose - there is no catalogue as far as I know.
Better ask for the libraries you want to use to get some infos
about that.

Welcome around CI Forums btw Wink

#3
[eluser]Nick_MyShuitings[/eluser]
Also, its not that hard to modify the library to make it work.

http://philsturgeon.co.uk/news/2010/05/u...gniter-2.0

I don't really subscribe to the attitude of expecting the contributed libraries to work right out of the box. Nor do a refrain from tampering with them. So messing around in them to make them work how I want them and with 2.0 isn't a real issue, and most of them would appreciate the push request (git) or the patch.

Also, several of the big name library writers, are purposefully not adding extra code to their libraries to make them backwards compatible, so if you go with 1.7.x then you will be missing out on those.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.